summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-10-21 22:46:56 +0000
committerAron Griffis <agriffis@gentoo.org>2001-10-21 22:46:56 +0000
commitcca77f9cc4924c9acc2807bc18af0b49fedc7954 (patch)
treed78d36128fd0f6e254d938b6c96c5b1e20e87372 /app-misc
parentFixup urls, tabbing, and try/die. (diff)
downloadhistorical-cca77f9cc4924c9acc2807bc18af0b49fedc7954.tar.gz
historical-cca77f9cc4924c9acc2807bc18af0b49fedc7954.tar.bz2
historical-cca77f9cc4924c9acc2807bc18af0b49fedc7954.zip
Changed lcdproc to use /etc/conf.d, along with other minor fixes.
Note that this ebuild installs to /usr/local/bin, which is wrong. It should install to /usr/bin.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lcdproc/files/digest-lcdproc-0.4.1-r11
-rw-r--r--app-misc/lcdproc/files/lcdproc7
-rw-r--r--app-misc/lcdproc/files/lcdproc.confd16
-rw-r--r--app-misc/lcdproc/lcdproc-0.4.1-r1.ebuild49
4 files changed, 69 insertions, 4 deletions
diff --git a/app-misc/lcdproc/files/digest-lcdproc-0.4.1-r1 b/app-misc/lcdproc/files/digest-lcdproc-0.4.1-r1
new file mode 100644
index 000000000000..499e295f1cb0
--- /dev/null
+++ b/app-misc/lcdproc/files/digest-lcdproc-0.4.1-r1
@@ -0,0 +1 @@
+MD5 85596a4572697bea971587f215097dcb lcdproc-0.4.1.tar.gz 212992
diff --git a/app-misc/lcdproc/files/lcdproc b/app-misc/lcdproc/files/lcdproc
index b965b2faa108..eb0efbfd3bd9 100644
--- a/app-misc/lcdproc/files/lcdproc
+++ b/app-misc/lcdproc/files/lcdproc
@@ -1,12 +1,11 @@
#!/sbin/runscript
+# Please don't change these variables. They are listed here as
+# defaults for reference. Make your modifications in
+# /etc/conf.d/lcdproc instead.
port="ttyS0"
-# which port is the LCD connected
driver="MtxOrb"
clients="C M T X"
-# "C" (CPU usage),"G" (CPU Graph like Xload),"M" (Memory Usage),"X" (X-Load),
-# "T" (Date, time, Uptime, OS version),"D" (Disk Stats),"B" (Battery Stats),"A" (About)
-# for more Clients see "LCDproc Homepage"
start() {
ebegin "Starting LCDProc"
diff --git a/app-misc/lcdproc/files/lcdproc.confd b/app-misc/lcdproc/files/lcdproc.confd
new file mode 100644
index 000000000000..1dae1f578f33
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc.confd
@@ -0,0 +1,16 @@
+# which port is the LCD connected
+port="ttyS0"
+
+# what driver should be used
+driver="MtxOrb"
+
+# "C" (CPU usage)
+# "G" (CPU Graph like Xload)
+# "M" (Memory Usage)
+# "X" (X-Load)
+# "T" (Date, time, Uptime, OS version)
+# "D" (Disk Stats)
+# "B" (Battery Stats)
+# "A" (About)
+# for more clients see "LCDproc Homepage"
+clients="C M T X"
diff --git a/app-misc/lcdproc/lcdproc-0.4.1-r1.ebuild b/app-misc/lcdproc/lcdproc-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..87bf9c98d5a5
--- /dev/null
+++ b/app-misc/lcdproc/lcdproc-0.4.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jens Blaesche <mr.big@pc-trouble.de>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+# 20 Sept.2001 / 16.30 CET
+
+S=${WORKDIR}/${P}
+DESCRIPTION="lcdproc - displays system status on Matrix-Orbital 20x4 LCD on a serial port."
+SRC_URI="http://lcdproc.omnipotent.net/${P}.tar.gz"
+HOMEPAGE="http://lcdproc.omnipotent.net/"
+
+DEPEND=">=baselayout-1.6.4"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+ make || die
+}
+
+src_install () {
+ exeinto /usr/local/bin
+ doexe server/LCDd
+ doexe clients/lcdproc/lcdproc
+ doman docs/lcdproc.1
+ dodoc README ChangeLog COPYING INSTALL
+ docinto docs
+ dodoc docs/README.dg docs/README.dg2 docs/hd44780_howto.txt docs/menustuff.txt docs/netstuff.txt
+ docinto clients/example
+ dodoc clients/examples/fortune.pl clients/examples/iosock.pl clients/examples/tail.pl clients/examples/x11amp.pl
+ docinto clients/headlines
+ dodoc clients/headlines/lcdheadlines
+
+ # /etc/init.d and /etc/conf.d installation
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/lcdproc
+ mkdir -p ${D}/etc/conf.d
+ install ${FILESDIR}/lcdproc.confd ${D}/etc/conf.d/lcdproc
+}
+
+pkg_postinst () {
+ rc-update add lcdproc default
+}
+
+pkg_postrm () {
+ rc-update del lcdproc
+}