summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-06-21 08:42:21 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-06-21 08:42:21 +0000
commit82c8876a27e8981700b340456251e90b9d2cf617 (patch)
treef203327c8e21253cffda32c30da991fd18f950c8 /app-office/karbon
parentUpdate for KOffice 1.4. (diff)
downloadhistorical-82c8876a27e8981700b340456251e90b9d2cf617.tar.gz
historical-82c8876a27e8981700b340456251e90b9d2cf617.tar.bz2
historical-82c8876a27e8981700b340456251e90b9d2cf617.zip
Final release of KOffice 1.4.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/files/digest-karbon-1.4.01
-rw-r--r--app-office/karbon/karbon-1.4.0.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 82756fa7dd62..79ebcd523fc5 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.6 2005/06/11 09:42:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.7 2005/06/21 08:37:53 greg_g Exp $
+
+*karbon-1.4.0 (21 Jun 2005)
+
+ 21 Jun 2005; Gregorio Guidi <greg_g@gentoo.org> +karbon-1.4.0.ebuild:
+ Final release of KOffice 1.4.
11 Jun 2005; Markus Rothe <corsair@gentoo.org> karbon-1.3.5.ebuild,
karbon-1.4.0_rc1.ebuild:
diff --git a/app-office/karbon/files/digest-karbon-1.4.0 b/app-office/karbon/files/digest-karbon-1.4.0
new file mode 100644
index 000000000000..aada0edc41ee
--- /dev/null
+++ b/app-office/karbon/files/digest-karbon-1.4.0
@@ -0,0 +1 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
diff --git a/app-office/karbon/karbon-1.4.0.ebuild b/app-office/karbon/karbon-1.4.0.ebuild
new file mode 100644
index 000000000000..4de35c22e2e3
--- /dev/null
+++ b/app-office/karbon/karbon-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.4.0.ebuild,v 1.1 2005/06/21 08:37:53 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.3
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}