summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-03 16:26:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-03 16:26:10 +0000
commit6ae03cbdfa869f55572738a44ef9ead07dd7d9b4 (patch)
tree4d971ccf3cab152f11625db131850903ebcc4666 /app-office/teapot/teapot-2.2.0.ebuild
parentStable on amd64, ppc64, x86 (diff)
downloadhistorical-6ae03cbdfa869f55572738a44ef9ead07dd7d9b4.tar.gz
historical-6ae03cbdfa869f55572738a44ef9ead07dd7d9b4.tar.bz2
historical-6ae03cbdfa869f55572738a44ef9ead07dd7d9b4.zip
Initial commit wrt #353579 by Kevin McCarthy.
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'app-office/teapot/teapot-2.2.0.ebuild')
-rw-r--r--app-office/teapot/teapot-2.2.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-office/teapot/teapot-2.2.0.ebuild b/app-office/teapot/teapot-2.2.0.ebuild
new file mode 100644
index 000000000000..fb5ce503a3fe
--- /dev/null
+++ b/app-office/teapot/teapot-2.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/teapot/teapot-2.2.0.ebuild,v 1.1 2011/02/03 16:26:10 ssuominen Exp $
+
+EAPI=4
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="A powerful spreadhseet program"
+HOMEPAGE="http://www.syntax-k.de/projekte/teapot/"
+SRC_URI="http://www.syntax-k.de/projekte/teapot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fltk"
+
+RDEPEND="sys-libs/ncurses
+ fltk? ( >=x11-libs/fltk-1.3.0_rc:1.1 )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-office/lyx
+ dev-tex/latex2html
+ dev-tex/pgf
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-doc-dir.patch
+ "${FILESDIR}"/${P}-helpfile.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable doc HELP)
+ -DPF=${PF}
+ )
+
+ if use fltk; then
+ mycmakeargs+=(
+ -DFLTK_USE_FILE=/usr/share/cmake/Modules/FLTKConfig.cmake
+ -DFLTK_DIR=/usr/share/cmake/Modules
+ -DFLTK_FLUID_EXECUTABLE=/usr/bin/fluid
+ )
+ append-cxxflags -I/usr/include/fltk-1.1
+ append-ldflags -L/usr/$(get_libdir)/fltk-1.1
+ fi
+
+ cmake-utils_src_configure
+}