summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-02-07 18:34:18 +0000
committerMarinus Schraal <foser@gentoo.org>2004-02-07 18:34:18 +0000
commit008b2da07de261ade0b45ec2521b1e0c8b7c447b (patch)
treed80eb6b2cd3661fb888e011b290409895fd5314d /app-office
parentNew release, mark 2.0.2 x86 (diff)
downloadhistorical-008b2da07de261ade0b45ec2521b1e0c8b7c447b.tar.gz
historical-008b2da07de261ade0b45ec2521b1e0c8b7c447b.tar.bz2
historical-008b2da07de261ade0b45ec2521b1e0c8b7c447b.zip
New release, mark 2.0.2 x86
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/Manifest6
-rw-r--r--app-office/abiword/abiword-2.0.2.ebuild6
-rw-r--r--app-office/abiword/abiword-2.0.3.ebuild96
-rw-r--r--app-office/abiword/files/digest-abiword-2.0.31
4 files changed, 103 insertions, 6 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 71e44d531635..73fa20208551 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,9 +1,9 @@
MD5 81d41cc62b92ac1adba7924fa528c48a abiword-2.0.0.ebuild 2215
MD5 7921df3134ed60f1eb9c3d1c920bde16 abiword-1.0.6-r1.ebuild 1927
-MD5 f238085ed52525abd2430c481cb92db1 abiword-2.0.2.ebuild 2255
+MD5 f70e67047c0307ca6a308c53c28e8b00 abiword-2.0.2.ebuild 2248
MD5 32730f5ef95f89d3f059ae26a72f7cbf abiword-2.0.1.ebuild 2171
-MD5 f238085ed52525abd2430c481cb92db1 abiword-2.0.3.ebuild 2255
-MD5 09c81ee9dfff979af5f156a10cd7392a ChangeLog 9203
+MD5 04a206dc6d2a3d70dd1cc53383a46752 abiword-2.0.3.ebuild 2134
+MD5 71856b61699b599ab6d84d5ccb86a223 ChangeLog 9305
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 53a88ebee6a70ad41f3eb428b4a3a3e7 files/digest-abiword-2.0.0 142
MD5 28dcae4a10f58c12a4a73346a7ab1ed0 files/digest-abiword-2.0.1 142
diff --git a/app-office/abiword/abiword-2.0.2.ebuild b/app-office/abiword/abiword-2.0.2.ebuild
index 6a6aa8a195f1..07de26fad443 100644
--- a/app-office/abiword/abiword-2.0.2.ebuild
+++ b/app-office/abiword/abiword-2.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.2.ebuild,v 1.1 2003/12/14 23:43:50 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.2.ebuild,v 1.2 2004/02/07 18:34:08 foser Exp $
inherit eutils
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.abisource.com"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+KEYWORDS="x86 ~sparc ~alpha ~ppc"
LICENSE="GPL-2"
SLOT="2"
diff --git a/app-office/abiword/abiword-2.0.3.ebuild b/app-office/abiword/abiword-2.0.3.ebuild
new file mode 100644
index 000000000000..34f16c2b3f8e
--- /dev/null
+++ b/app-office/abiword/abiword-2.0.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.3.ebuild,v 1.1 2004/02/07 18:34:08 foser Exp $
+
+inherit eutils
+
+IUSE="spell jpeg xml2 gnome debug"
+
+S=${WORKDIR}/${P}/abi
+S_P=${WORKDIR}/${P}/${PN}-plugins
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ ( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
+ spell? ( >=app-text/enchant-1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2.1
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonobo-2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ # this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
+ # The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
+ cp configure configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
+
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+ econf \
+ `use_enable debug` \
+ --enable-all \
+ --with-abiword=${S} \
+ --without-ImageMagick || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:Exec=abiword:Exec=abiword-2.0:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+}
diff --git a/app-office/abiword/files/digest-abiword-2.0.3 b/app-office/abiword/files/digest-abiword-2.0.3
new file mode 100644
index 000000000000..a253760d64df
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.0.3
@@ -0,0 +1 @@
+MD5 aa97aec08c353356dcb95b7634b56e9d abiword-2.0.3.tar.bz2 22072758