summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-07-01 10:45:20 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-07-01 10:45:20 +0000
commit9ec60e33abb979213c0acd1b414448999b076b2d (patch)
tree2ab7072b36ecbc1baf45c868fbc191c10f1bab87 /app-officeext/ooofbtools/ooofbtools-2.36.ebuild
parentInitial commit. (diff)
downloadhistorical-9ec60e33abb979213c0acd1b414448999b076b2d.tar.gz
historical-9ec60e33abb979213c0acd1b414448999b076b2d.tar.bz2
historical-9ec60e33abb979213c0acd1b414448999b076b2d.zip
Version bump, wrt bug #552258
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0x60C0742D1F357D42
Diffstat (limited to 'app-officeext/ooofbtools/ooofbtools-2.36.ebuild')
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.36.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-officeext/ooofbtools/ooofbtools-2.36.ebuild b/app-officeext/ooofbtools/ooofbtools-2.36.ebuild
new file mode 100644
index 000000000000..cb45cf734ba9
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.36.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/ooofbtools/ooofbtools-2.36.ebuild,v 1.1 2015/07/01 10:45:17 pinkbyte Exp $
+
+EAPI=5
+
+MY_PN="OOoFBTools"
+
+OFFICE_EXTENSIONS=(
+ "${MY_PN}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Extension for converting and processing eBooks in FictionBook2 format with validator"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/libxml2"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" 2>/dev/null
+ rm -r win32 || die
+ popd 2>/dev/null
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}