summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-01-27 02:42:04 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-01-27 02:42:04 +0000
commitf2c971a206af049e8d78dd85415f80654232392f (patch)
tree1fa460ebf6a60fb57588925b9e41e3fec0fb0f6c /app-pda
parentDisable stack-protector on C++ for <gcc-4, bug #230119. (diff)
downloadhistorical-f2c971a206af049e8d78dd85415f80654232392f.tar.gz
historical-f2c971a206af049e8d78dd85415f80654232392f.tar.bz2
historical-f2c971a206af049e8d78dd85415f80654232392f.zip
fix install location of hal scripts - in a better way
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/synce-hal/Manifest2
-rw-r--r--app-pda/synce-hal/synce-hal-0.13.ebuild13
2 files changed, 7 insertions, 8 deletions
diff --git a/app-pda/synce-hal/Manifest b/app-pda/synce-hal/Manifest
index 28b31c8859c2..cf7ba7290fd0 100644
--- a/app-pda/synce-hal/Manifest
+++ b/app-pda/synce-hal/Manifest
@@ -2,7 +2,7 @@ DIST synce-hal-0.1.tar.gz 357944 RMD160 77fe161acca8930cdefd2ea952d7d9f8cc44ec7a
DIST synce-hal-0.13.tar.gz 312966 RMD160 f962ddca017c38efd063abec26da4ad0452d982f SHA1 a9eba0574ff1248253b3eaad08b8d19af58f1042 SHA256 86cbe4d173976e08878b2ceba405b20388dd203a90d2fbc816ecf7de3fe5896e
DIST synce-hal-0.2.tar.gz 358413 RMD160 760f0c3af4a2c12ce2a3107c20a158ecc77b9402 SHA1 92116494533016c5e6ae206b012aa0dd00b126cd SHA256 3ac94e8bf92108ef84862f93c5bbd3af534476890b0ba157352cf8ee929afef4
EBUILD synce-hal-0.1.ebuild 885 RMD160 551954b458e86e0dca1fa98a332023f881de813a SHA1 4ec98e14e2d6851ea360f279ad7abccab798299f SHA256 bf418bc1ff604b8e1a59a60150813ad970a962efd95dd92527082cc7f62f2582
-EBUILD synce-hal-0.13.ebuild 1236 RMD160 71c573028e165132544c86cdf669bca598817463 SHA1 1fd0bcc5e6b17e3be99f6eccd4c168b8d0c5e7fd SHA256 295d4cfd6bdda7e79efe136ceacdd5dd0d2053e451ce859fee2429281f11dddb
+EBUILD synce-hal-0.13.ebuild 1126 RMD160 8ee4d8efdf39e91e1759144da9db05033f5b6734 SHA1 e2e3e5f6f4d5c7c1019c7b9b0d5d66e46cbe0f76 SHA256 26a7808ad470b50aa5353b7f0d00584c617d9bbc006047082ad25a7fb18851b6
EBUILD synce-hal-0.2.ebuild 885 RMD160 d0ac7f9ee6b50b2c7c100d753943a9981a404a5d SHA1 20d225b9d3c998fc5ef4b8561bb6de6f3b26010c SHA256 5885b22807ffcbc71cc221c47c5d926a964aa19b16ce34ca44dee52e679ea97e
MISC ChangeLog 1129 RMD160 c889c91e1327559cb36807b8ff451f95bcc16732 SHA1 4de9fe2c03906cb3d72c603f0b3ca8e8bf26a644 SHA256 04594cd05c8861d41dcc6a17f11f34506d4984c038c09163a7ec49bdac76902a
MISC metadata.xml 632 RMD160 1e704a636dc925defbf15fafd9f3f559d7e1bac4 SHA1 f01e3e8d7d988a0d92eab16699f75058d2f2e2ba SHA256 9596527e2bdc4133b62949ae92c161decad64b17948475dfc4bc658e3a83e668
diff --git a/app-pda/synce-hal/synce-hal-0.13.ebuild b/app-pda/synce-hal/synce-hal-0.13.ebuild
index fcedbd82f139..640f51aa96cd 100644
--- a/app-pda/synce-hal/synce-hal-0.13.ebuild
+++ b/app-pda/synce-hal/synce-hal-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/synce-hal-0.13.ebuild,v 1.4 2009/01/27 02:32:21 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/synce-hal-0.13.ebuild,v 1.5 2009/01/27 02:42:04 mescalinum Exp $
inherit multilib versionator
@@ -28,16 +28,15 @@ RDEPEND="${DEPEND}
SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+src_compile() {
+ econf --with-hal-addon-dir="/usr/$(get_libdir)/hal/scripts" || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS README ChangeLog || die
# fix collision with app-pda/synce-serial, bug 246675
rm -f "${D}/usr/libexec/synce-serial-chat"
-
- # fix install location of hal scripts
- local hal_dir="/usr/$(get_libdir)/hal"
- local hal_scripts_dir="${hal_dir}/scripts"
- dodir "${hal_scripts_dir}"
- mv "${D}${hal_dir}"/hal-synce-* "${D}${hal_scripts_dir}/"
}