summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-02-25 22:51:26 +0000
committerMichael Imhof <tantive@gentoo.org>2003-02-25 22:51:26 +0000
commit3abc6b7820caac5745f7a592e8cb38e1c7a748d8 (patch)
treee486ddda2da7942b481fa591829849ed752ac52d /app-sci
parentFixed dependencies. Closes #16353. (diff)
downloadhistorical-3abc6b7820caac5745f7a592e8cb38e1c7a748d8.tar.gz
historical-3abc6b7820caac5745f7a592e8cb38e1c7a748d8.tar.bz2
historical-3abc6b7820caac5745f7a592e8cb38e1c7a748d8.zip
Closes #16349
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/zetagrid/files/digest-zetagrid-1.0-r52
-rw-r--r--app-sci/zetagrid/zetagrid-1.0-r5.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/app-sci/zetagrid/files/digest-zetagrid-1.0-r5 b/app-sci/zetagrid/files/digest-zetagrid-1.0-r5
new file mode 100644
index 000000000000..13ffefbbaa20
--- /dev/null
+++ b/app-sci/zetagrid/files/digest-zetagrid-1.0-r5
@@ -0,0 +1,2 @@
+MD5 6140753720c3276f348aa5c855ad6079 zeta_cmd.zip 46403
+MD5 fce1921170a936c7b234ec071953eea5 zeta_progress.zip 5874
diff --git a/app-sci/zetagrid/zetagrid-1.0-r5.ebuild b/app-sci/zetagrid/zetagrid-1.0-r5.ebuild
new file mode 100644
index 000000000000..64058fb248d6
--- /dev/null
+++ b/app-sci/zetagrid/zetagrid-1.0-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/zetagrid/zetagrid-1.0-r5.ebuild,v 1.1 2003/02/25 22:51:26 tantive Exp $
+
+S=${WORKDIR}/zetagrid-${PV}
+DESCRIPTION="An open source and platform independent grid system"
+SRC_URI="http://www.zetagrid.net/zeta/zeta_cmd.zip http://www.zetagrid.net/zeta/add-ons/zeta_progress.zip"
+HOMEPAGE="http://www.zetagrid.net http://cvs.gentoo.org/~tantive"
+IUSE=""
+
+DEPEND="virtual/glibc
+ app-arch/unzip"
+RDEPEND="virtual/jre
+ >=sys-libs/lib-compat-1.1"
+SLOT="0"
+LICENSE="unknown"
+KEYWORDS="x86 ppc -sparc alpha"
+
+src_unpack() {
+ unpack zeta_cmd.zip zeta_progress.zip
+ if test -e /opt/zetagrid/zeta.cfg; then
+ cp /opt/zetagrid/zeta.cfg ${WORKDIR}/zeta.cfg
+ fi
+}
+
+src_install() {
+ dodir /opt/zetagrid
+ cp ${FILESDIR}/zeta.sh ${D}/opt/zetagrid
+ cp ${FILESDIR}/zeta_progress.sh ${D}/opt/zetagrid
+ cp ${WORKDIR}/* ${D}/opt/zetagrid
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/zetagrid.init zetagrid
+}
+
+pkg_postinst() {
+ einfo "Zetagrid is now installed in /opt/zetagrid"
+ einfo "Please change zeta.cfg for configuration issues!"
+ einfo "More information about setup can be found at"
+ einfo "http://cvs.gentoo.org/~tantive"
+ einfo
+ einfo "Zetagrid can be started using zeta.sh"
+ einfo "Progress information is displayed by zeta_progress.sh or"
+ einfo "by "java -cp zeta_progress.jar zeta.JShowProgress"."
+ einfo
+ ewarn "If you're getting an error at first execution"
+ ewarn "please run it a second time, this issue is known"
+ ewarn "and only happens at the very first start."
+}
+