summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-09-11 17:48:16 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-09-11 17:48:16 +0000
commit95230485a5305e5b889ee62f8b5067ec0eee52f7 (patch)
tree56ddcf8778ea338b63386a571dbf68cc0a74e2f8 /app-shells/dash/dash-0.5.1.3.ebuild
parenttaking package mask out of uclibc/embeded/hardened profiles (diff)
downloadhistorical-95230485a5305e5b889ee62f8b5067ec0eee52f7.tar.gz
historical-95230485a5305e5b889ee62f8b5067ec0eee52f7.tar.bz2
historical-95230485a5305e5b889ee62f8b5067ec0eee52f7.zip
version bump; updated ebuild to use versionator.eclass
Diffstat (limited to 'app-shells/dash/dash-0.5.1.3.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.1.3.ebuild b/app-shells/dash/dash-0.5.1.3.ebuild
new file mode 100644
index 000000000000..33acf8f649ca
--- /dev/null
+++ b/app-shells/dash/dash-0.5.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.1.3.ebuild,v 1.1 2004/09/11 17:48:16 ka0ttic Exp $
+
+inherit eutils versionator
+
+IUSE=""
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P=${MY_P2/_/-}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-devel/pmake
+ sys-apps/sed
+ dev-util/yacc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${DEB_P}.diff
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+
+ newman src/dash.1 dash.1
+
+ dodoc COPYING debian/changelog
+}