summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-24 21:51:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-24 21:51:37 +0000
commit32abe9c9c2287517e3c3ff52797dbefa2cdbc834 (patch)
tree08b6c284311857197438d2dd9744359b077afdcd /app-shells/ksh/ksh-93.20071105.ebuild
parentVersion bump, bug #295867. Clean up old revisions. (diff)
downloadhistorical-32abe9c9c2287517e3c3ff52797dbefa2cdbc834.tar.gz
historical-32abe9c9c2287517e3c3ff52797dbefa2cdbc834.tar.bz2
historical-32abe9c9c2287517e3c3ff52797dbefa2cdbc834.zip
blah, bin/pcakage gets run multiple times, so sed the script
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-shells/ksh/ksh-93.20071105.ebuild')
-rw-r--r--app-shells/ksh/ksh-93.20071105.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-shells/ksh/ksh-93.20071105.ebuild b/app-shells/ksh/ksh-93.20071105.ebuild
index c3b844e5640e..59f30cdf40c0 100644
--- a/app-shells/ksh/ksh-93.20071105.ebuild
+++ b/app-shells/ksh/ksh-93.20071105.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.7 2010/01/24 19:11:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.8 2010/01/24 21:51:37 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -38,9 +38,11 @@ src_unpack() {
# INIT provides the basic tools to start building.
unpack INIT.${INIT_RELEASE}.tgz
- # `package read` will unpack any tarballs put in place.
# run through /bin/sh due to #141906
- /bin/sh "${S}"/bin/package read || die
+ sed -i '1i#!/bin/sh' "${S}"/bin/package || die
+
+ # `package read` will unpack any tarballs put in place.
+ "${S}"/bin/package read || die
}
src_compile() {