summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-05-01 12:37:50 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-05-01 12:37:50 +0000
commitdcafd052bff3b5aac767d624bced8beb15a85009 (patch)
tree65e854d0eb78439ffa7fc6d9328cbc8cb1b3f9b7 /app-shells
parentMoved net-misc/guarddog to net-firewall/guarddog. Closes #18428. (diff)
downloadhistorical-dcafd052bff3b5aac767d624bced8beb15a85009.tar.gz
historical-dcafd052bff3b5aac767d624bced8beb15a85009.tar.bz2
historical-dcafd052bff3b5aac767d624bced8beb15a85009.zip
Fixing segfault on empty herestring.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/Manifest5
-rw-r--r--app-shells/bash/bash-2.05b-r5.ebuild82
-rw-r--r--app-shells/bash/files/bash-2.05b-empty-herestring.patch27
-rw-r--r--app-shells/bash/files/digest-bash-2.05b-r55
5 files changed, 125 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 16b376d2fc97..dbe95d58cee1 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.5 2003/04/27 11:12:10 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.6 2003/05/01 12:37:50 taviso Exp $
+
+*bash-2.05b-r5 (01 May 2003)
+
+ 01 May 2003; Tavis Ormandy <taviso@gentoo.org> bash-2.05b-r5.ebuild,
+ files/bash-2.05b-empty-herestring.patch:
+ Fixing segfault on empty herestring.
*bash-2.05b-r4 (27 Apr 2003)
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index ea4097c1045a..426a16eecbd8 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,9 +1,12 @@
-MD5 e2f0ea58aab18a1a7bd0440dc4b18be7 ChangeLog 3862
+MD5 06217d12e3cc445e16d2b2aef104c617 ChangeLog 4046
MD5 ba1233983751e50700241a6495306378 bash-2.05a-r3.ebuild 1917
MD5 31f9be8380509135728cb39c2c0fb8b4 bash-2.05b-r3.ebuild 1759
MD5 07f6d15b69c9c92332ab6f0f2df6343c bash-2.05b-r4.ebuild 1870
+MD5 7b908cade3f05deecfa57bae56dc0271 bash-2.05b-r5.ebuild 1851
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
MD5 555c6b4000bd9d5557f5627530e13ec4 files/digest-bash-2.05a-r3 63
MD5 867b3b11e48acac6d09794c8d36cb204 files/digest-bash-2.05b-r3 296
MD5 90ba92c981c1d26e45d88ecd23a1fbf5 files/bash-2.05b-multibyte-locale.patch 1897
+MD5 edf95b873162f4548435c379e4998b4e files/bash-2.05b-empty-herestring.patch 836
MD5 867b3b11e48acac6d09794c8d36cb204 files/digest-bash-2.05b-r4 296
+MD5 b9e9f988b28475ed5f633dc471296297 files/digest-bash-2.05b-r5 291
diff --git a/app-shells/bash/bash-2.05b-r5.ebuild b/app-shells/bash/bash-2.05b-r5.ebuild
new file mode 100644
index 000000000000..b9184cc1d39b
--- /dev/null
+++ b/app-shells/bash/bash-2.05b-r5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r5.ebuild,v 1.1 2003/05/01 12:37:50 taviso Exp $
+
+inherit eutils flag-o-matic
+
+# Official patches
+PLEVEL="x002 x003 x004"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ # Remove autoconf dependency
+ cp Makefile.in Makefile.in.orig
+ sed -e "/&& autoconf/d" Makefile.in.orig > Makefile.in
+
+ # Readline is slow with multibyte locale, bug #19762
+ epatch ${FILESDIR}/${P}-multibyte-locale.patch
+ # Segfault on empty herestring
+ epatch ${FILESDIR}/${P}-empty-herestring.patch
+}
+
+src_compile() {
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ use build \
+ && rm -rf ${D}/usr \
+ || ( \
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ )
+}
diff --git a/app-shells/bash/files/bash-2.05b-empty-herestring.patch b/app-shells/bash/files/bash-2.05b-empty-herestring.patch
new file mode 100644
index 000000000000..62e231c646f5
--- /dev/null
+++ b/app-shells/bash/files/bash-2.05b-empty-herestring.patch
@@ -0,0 +1,27 @@
+###################################################################
+# Added by Tavis Ormandy <taviso@gentoo.org> 01/05/2003
+# Reproduce with
+#
+# $ xargs <<< ${EMTPY_VARIABLE}
+# Segmentation fault.
+#
+# note: bash will still give you a "\n" with this patch, but this is
+# standard behaviour, if you need proof:
+#
+# $ wc -l <<< ""
+###############################
+diff -u bash-2.05b.orig/redir.c bash-2.05b/redir.c
+--- bash-2.05b.orig/redir.c 2002-03-12 20:27:38.000000000 +0000
++++ bash-2.05b/redir.c 2003-05-01 13:04:07.000000000 +0100
+@@ -263,8 +263,10 @@
+ int herelen, n, e;
+
+ herestr = expand_string_to_string (redirectee->word, 0);
+- herelen = strlen (herestr);
+
++ /* verify string wasnt empty */
++ herelen = (herestr == NULL) ? 0 : strlen (herestr);
++
+ n = write (fd, herestr, herelen);
+ if (n == herelen)
+ {
diff --git a/app-shells/bash/files/digest-bash-2.05b-r5 b/app-shells/bash/files/digest-bash-2.05b-r5
new file mode 100644
index 000000000000..fa876202be5d
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-2.05b-r5
@@ -0,0 +1,5 @@
+MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 195621
+MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 274
+MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 75
+MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 235
+MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 111