summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2005-12-18 00:31:44 +0000
committerJeroen Roovers <jer@gentoo.org>2005-12-18 00:31:44 +0000
commitfe06eff2a7f3ae70eb37f4ca661043db51925724 (patch)
tree8b22fd360768fc8c75488101de495a4a0b41e21b /app-text/an
parentMarked 0.1.19-r1 stable for mips,sparc,x86. (diff)
downloadhistorical-fe06eff2a7f3ae70eb37f4ca661043db51925724.tar.gz
historical-fe06eff2a7f3ae70eb37f4ca661043db51925724.tar.bz2
historical-fe06eff2a7f3ae70eb37f4ca661043db51925724.zip
Gunzipped the files/*.diff.gz
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'app-text/an')
-rw-r--r--app-text/an/ChangeLog6
-rw-r--r--app-text/an/Manifest6
-rw-r--r--app-text/an/an-0.95.3.ebuild7
-rw-r--r--app-text/an/files/an_0.95-3.diff357
-rw-r--r--app-text/an/files/an_0.95-3.diff.gzbin3274 -> 0 bytes
5 files changed, 367 insertions, 9 deletions
diff --git a/app-text/an/ChangeLog b/app-text/an/ChangeLog
index ecb7a30fb60b..cdf5cbd017bf 100644
--- a/app-text/an/ChangeLog
+++ b/app-text/an/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/an
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.14 2005/12/12 02:16:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.15 2005/12/18 00:31:43 jer Exp $
+
+ 18 Dec 2005; Jeroen Roovers <jer@gentoo.org> +files/an_0.95-3.diff,
+ -files/an_0.95-3.diff.gz, an-0.95.3.ebuild:
+ Gunzipped the files/*.diff.gz
12 Dec 2005; Jeroen Roovers <jer@gentoo.org> -an-0.93.ebuild:
Removed an 0.93 as suggested in bug #113966, comment #7.
diff --git a/app-text/an/Manifest b/app-text/an/Manifest
index 0e6848f10876..1b92a6986d8d 100644
--- a/app-text/an/Manifest
+++ b/app-text/an/Manifest
@@ -1,5 +1,5 @@
-MD5 ba75de5fc3bdf1a8526a5ed1e9d9367d ChangeLog 1927
-MD5 20264133e503941de3247e81bce1b4f9 an-0.95.3.ebuild 2148
-MD5 3c78113d8bab704b1a33eeaf444ae045 files/an_0.95-3.diff.gz 3274
+MD5 c27a1c5286a8716e2263e540ea2f3109 ChangeLog 2076
+MD5 fd7809543c2c44de8ba34749793b8d83 an-0.95.3.ebuild 2111
+MD5 b2b9cb057b042a992612c0d36dff2d40 files/an_0.95-3.diff 9803
MD5 0ae7dd4d477690add5b47402eb50b946 files/digest-an-0.95.3 63
MD5 3c2afaa2ec4bbe2e6a014f61423fd746 metadata.xml 360
diff --git a/app-text/an/an-0.95.3.ebuild b/app-text/an/an-0.95.3.ebuild
index 425e84f8671b..c43d25475a67 100644
--- a/app-text/an/an-0.95.3.ebuild
+++ b/app-text/an/an-0.95.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.ebuild,v 1.7 2005/12/11 07:04:51 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.ebuild,v 1.8 2005/12/18 00:31:43 jer Exp $
inherit eutils toolchain-funcs versionator
@@ -25,7 +25,7 @@ src_unpack() {
# Patching to -r3:
MY_PL="$(replace_version_separator 2 -)"
- epatch "${FILESDIR}"/${PN}_${MY_PL}.diff.gz
+ epatch "${FILESDIR}"/${PN}_${MY_PL}.diff
ebegin "Patching an to use toolchain and custom CFLAGS"
sed -e "s:gcc:$(tc-getCC):" \
@@ -38,9 +38,6 @@ src_unpack() {
-e 's:/usr/dict/words:/usr/share/dict/words:' \
-i README || die
}
-src_compile() {
- emake || die
-}
src_install() {
dobin ${PN} || die
diff --git a/app-text/an/files/an_0.95-3.diff b/app-text/an/files/an_0.95-3.diff
new file mode 100644
index 000000000000..9879211cca6a
--- /dev/null
+++ b/app-text/an/files/an_0.95-3.diff
@@ -0,0 +1,357 @@
+--- an-0.95.orig/an.c
++++ an-0.95/an.c
+@@ -863,7 +863,7 @@
+
+ /* If letter is punctuation go to next letter */
+
+- if (letterpos[(int)letter] == -1)
++ if (letterpos[(unsigned char)letter] == -1)
+ continue;
+
+ /* Check if letter is available for use (useit==TRUE) */
+@@ -1031,7 +1031,7 @@
+ have_a_letter = FALSE;
+ have_a_digit = FALSE;
+ for (temp_string = line; *temp_string; temp_string++) {
+- if (letterpos[(int)*temp_string]!=-1)
++ if (letterpos[(unsigned char)*temp_string]!=-1)
+ have_a_letter = TRUE;
+ if (isdigit (*temp_string)) {
+ have_a_digit = TRUE;
+@@ -1199,7 +1199,7 @@
+
+ for (; *word != '\0'; word++) {
+ /* If letter is punctuation mark skip to next letter */
+- int l = letterpos[(int)*word];
++ int l = letterpos[(unsigned char)*word];
+
+ if (l == -1)
+ continue;
+@@ -1238,10 +1238,10 @@
+ while (loop1--) {
+ tmpptr = *words++;
+ for (; *tmpptr != '\0'; tmpptr++) {
+- if (letterpos[(int)*tmpptr]==-1)
++ if (letterpos[(unsigned char)*tmpptr]==-1)
+ continue;
+ else
+- letter_freq[letterpos[(int)*tmpptr]]++;
++ letter_freq[letterpos[(unsigned char)*tmpptr]]++;
+ }
+ }
+
+@@ -1303,8 +1303,8 @@
+
+ /* First sort words by frequency of first letter */
+
+- if (letter_freq[letterpos[(int)*tmp_word1]] <
+- letter_freq[letterpos[(int)*tmp_word2]]) {
++ if (letter_freq[letterpos[(unsigned char)*tmp_word1]] <
++ letter_freq[letterpos[(unsigned char)*tmp_word2]]) {
+
+ #ifdef FORCE_ANSI
+ free (tmp_word1);
+@@ -1314,8 +1314,8 @@
+ return (-1);
+ }
+ else {
+- if (letter_freq[letterpos[(int)*tmp_word1]] >
+- letter_freq[letterpos[(int)*tmp_word2]]) {
++ if (letter_freq[letterpos[(unsigned char)*tmp_word1]] >
++ letter_freq[letterpos[(unsigned char)*tmp_word2]]) {
+
+ #ifdef FORCE_ANSI
+ free (tmp_word1);
+@@ -1397,22 +1397,22 @@
+
+ /* Check to make sure punctuation appears at the end of words */
+
+- if (letterpos[(int)*let1]==-1) {
+- if (letterpos[(int)*let2]==-1)
++ if (letterpos[(unsigned char)*let1]==-1) {
++ if (letterpos[(unsigned char)*let2]==-1)
+ return 0;
+ else
+ return 1;
+ }
+
+- if (letterpos[(int)*let2]==-1)
++ if (letterpos[(unsigned char)*let2]==-1)
+ return -1;
+
+
+- if (letter_freq[letterpos[(int)*let1]] <
+- letter_freq[letterpos[(int)*let2]])
++ if (letter_freq[letterpos[(unsigned char)*let1]] <
++ letter_freq[letterpos[(unsigned char)*let2]])
+ return (-1);
+- else if (letter_freq[letterpos[(int)*let1]] >
+- letter_freq[letterpos[(int)*let2]])
++ else if (letter_freq[letterpos[(unsigned char)*let1]] >
++ letter_freq[letterpos[(unsigned char)*let2]])
+ return (1);
+
+ if (*let1 < *let2)
+@@ -1438,13 +1438,13 @@
+ int c2;
+
+ do {
+- if (letterpos[(int)*s1]==-1) {
+- if (letterpos[(int)*s2]==-1)
++ if (letterpos[(unsigned char)*s1]==-1) {
++ if (letterpos[(unsigned char)*s2]==-1)
+ return 0;
+ else
+ return 1;
+ }
+- if (letterpos[(int)*s2]==-1)
++ if (letterpos[(unsigned char)*s2]==-1)
+ return 1;
+ while (*(s1 + 1) == *s1)
+ s1++;
+@@ -1455,8 +1455,8 @@
+ if (*s2 == '\0')
+ return -1;
+
+- c1 = letter_freq[letterpos[(int)*s1]];
+- c2 = letter_freq[letterpos[(int)*s2]];
++ c1 = letter_freq[letterpos[(unsigned char)*s1]];
++ c2 = letter_freq[letterpos[(unsigned char)*s2]];
+ }
+ while (*s1++ == *s2++);
+
+@@ -1587,7 +1587,7 @@
+ for (tmp_string = string; *tmp_string != '\0'; tmp_string++) {
+ /* If current letter is punctuation mark skip to next letter */
+
+- if (letterpos[(int)*tmp_string]==-1)
++ if (letterpos[(unsigned char)*tmp_string]==-1)
+ continue;
+
+ /* Copy letter into NEW_STRING */
+@@ -1618,7 +1618,7 @@
+ for (; *string != '\0'; string++) {
+ /* If letter punctuation mark skip to next letter */
+
+- if (letterpos[(int)*string]==-1)
++ if (letterpos[(unsigned char)*string]==-1)
+ continue;
+
+ /* Add 1 to LENGTH */
+--- an-0.95.orig/Makefile
++++ an-0.95/Makefile
+@@ -34,7 +34,8 @@
+
+ #DEFS=-DFORCE_ANSI
+
+-CFLAGS=-O2 -Wall -I $(LIBDIR) $(DEFS)
++CFLAGS=-O2 -Wall
++CINCLUDES=-I $(LIBDIR) $(DEFS)
+
+ # Nothing should need changing below here
+
+@@ -47,7 +48,7 @@
+
+
+ $(BIN): $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) $(CINCLUDES) -o $(BIN) $(OBJS)
+ $(OBJS): gan.h
+ $(MAN):
+
+@@ -63,7 +64,7 @@
+
+
+ with-getopt: $(OBJS) $(GETOPT)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(GETOPT)
++ $(CC) $(CFLAGS) $(CINCLUDES) -o $(BIN) $(OBJS) $(GETOPT)
+
+ install: $(BIN) $(INSTALLDIR)/$(BIN) $(MANDIR)/$(MAN)
+
+--- an-0.95.orig/an.6
++++ an-0.95/an.6
+@@ -1,5 +1,4 @@
+-.\" "%W% %G%"
+-.TH AN\ 0.93 6
++.TH AN 6
+ .SH NAME
+ an \- Anagram generator
+ .SH SYNOPSIS
+@@ -11,7 +10,7 @@
+ .SH DESCRIPTION
+ .B an
+ finds all anagrams which can be made from the letters in \fBPHRASE\fP,
+-using words in the specified dictionary (default=/usr/dict/words).
++using words in the specified dictionary (default=/usr/share/dict/words).
+ .SH OPTIONS
+ .TP
+ .I \-w, --words
+@@ -79,10 +78,3 @@
+ Please report any bugs to richard@deep-thought.org
+
+ Suggestions and contributions are also welcome.
+-
+-
+-
+-
+-
+-
+-
+--- an-0.95.orig/COPYRIGHT
++++ an-0.95/COPYRIGHT
+@@ -1,7 +1,7 @@
+ an v0.94 - Anagram generator
+ Copyright (C) 1996 Free Software Foundation.
+ Copyright (C) 1995,1996 Richard Jones
+- Copyright (C) 2001 Paul Martin
++ Copyright (C) 2001-2004 Paul Martin
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+--- an-0.95.orig/debian/changelog
++++ an-0.95/debian/changelog
+@@ -1,3 +1,21 @@
++an (0.95-3) unstable; urgency=low
++
++ * Bugfixes:
++ - Fix manpage to refer to /usr/share/dict/words instead of
++ /usr/dict/words (Closes: #249362)
++ * Standards-version: 3.6.1
++ * Building with debhelper 4
++
++ -- Paul Martin <pm@debian.org> Wed, 19 May 2004 17:38:41 +0100
++
++an (0.95-2) unstable; urgency=low
++
++ * Bugfix: (Closes: #164514)
++ - Made all casts into letterpos[] be "unsigned char". This is a
++ related bug to the one fixed in #145848.
++
++ -- Paul Martin <pm@debian.org> Sun, 13 Oct 2002 03:11:36 +0100
++
+ an (0.95-1) unstable; urgency=low
+
+ * Bugfixes: (Closes: #145848)
+--- an-0.95.orig/debian/copyright
++++ an-0.95/debian/copyright
+@@ -2,7 +2,8 @@
+ on Mon, 13 Nov 2000 17:53:04 +0000.
+
+ The original source can always be found at:
+- ftp://ftp.debian.org/dists/unstable/main/source/games/
++
++ http://ftp.debian.org/pool/main/a/an/
+
+ The original author of this program, who appears to have disappeared,
+ was Richard Jones <richard@deep-thought.org>.
+@@ -10,7 +11,7 @@
+ an v0.93 - Anagram generator
+ Copyright (C) 1996 Free Software Foundation.
+ Copyright (C) 1995,1996 Richard Jones
+- Portions copyright (C) 2000 Paul Martin
++ Portions copyright (C) 2000-2004 Paul Martin
+
+
+ This program is free software; you can redistribute it and/or modify
+--- an-0.95.orig/debian/README.Debian
++++ an-0.95/debian/README.Debian
+@@ -4,7 +4,11 @@
+ The original author has become unreachable, so I've taken over this
+ package in his absence.
+
+-The major change so far is that an now looks at /usr/share/dict/words by
+-default.
++The major changes:
+
+- -- Paul Martin <pm@debian.org>, Mon, 13 Nov 2000 17:53:04 +0000
++an looks at /usr/share/dict/words by default instead of /usr/dict/words.
++
++an is capable of working with languages other than English, with
++alphabets of up to 64 letters.
++
++ -- Paul Martin <pm@debian.org>, Wed, 19 May 2004 17:17:25 +0100
+--- an-0.95.orig/debian/control
++++ an-0.95/debian/control
+@@ -2,14 +2,14 @@
+ Section: games
+ Priority: optional
+ Maintainer: Paul Martin <pm@debian.org>
+-Build-Depends: debhelper (>=3)
+-Standards-Version: 3.5.4
++Build-Depends: debhelper (>=4)
++Standards-Version: 3.6.1
+
+ Package: an
+ Architecture: any
+ Depends: ${shlibs:Depends}
+-Recommends: wordlist
+-Description: Very fast anagram generator.
++Recommends: wenglish|wordlist
++Description: very fast anagram generator
+ Generates anagrams for a phrase supplied by the user, the words used in the
+ anagram are taken from a specified dictionary which should contain one word
+ per line (default:/usr/share/dict/words). Appears to be up to 10 times
+--- an-0.95.orig/debian/rules
++++ an-0.95/debian/rules
+@@ -5,11 +5,25 @@
+ # Uncomment this to turn on verbose mode.
+ #export DH_VERBOSE=1
+
+-# This is the debhelper compatability version to use.
+-export DH_COMPAT=3
+-
+ package = an
+
++CFLAGS = -Wall -g
++INSTALL = install
++INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
++INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
++INSTALL_SCRIPT = $(INSTALL) -p -o root -g root -m 755
++INSTALL_DIR = $(INSTALL) -p -d -o root -g root -m 755
++
++ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
++CFLAGS += -O0
++else
++CFLAGS += -O2
++endif
++ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
++INSTALL_PROGRAM += -s
++endif
++
++
+ configure: configure-stamp
+ configure-stamp:
+ dh_testdir
+@@ -23,8 +37,7 @@
+ dh_testdir
+
+ # Add here commands to compile the package.
+- $(MAKE)
+- #/usr/bin/docbook-to-man debian/an.sgml > an.1
++ $(MAKE) CFLAGS="$(CFLAGS)"
+
+ touch build-stamp
+
+@@ -45,7 +58,8 @@
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+- $(MAKE) install DESTDIR=$(CURDIR)/debian/$(package)
++ $(INSTALL_PROGRAM) $(CURDIR)/an \
++ $(CURDIR)/debian/$(package)/usr/games/an
+
+
+ # Build architecture-independent files here.
+@@ -64,7 +78,7 @@
+ # dh_installpam
+ # dh_installinit
+ # dh_installcron
+- dh_installman
++ dh_installman an.6
+ # dh_installinfo
+ # dh_undocumented
+ dh_installchangelogs
+--- an-0.95.orig/debian/compat
++++ an-0.95/debian/compat
+@@ -0,0 +1 @@
++4
diff --git a/app-text/an/files/an_0.95-3.diff.gz b/app-text/an/files/an_0.95-3.diff.gz
deleted file mode 100644
index e9ae322c91e7..000000000000
--- a/app-text/an/files/an_0.95-3.diff.gz
+++ /dev/null
Binary files differ