summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-18 14:11:49 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-18 14:11:49 +0000
commit0e53f9129a3ccc5a646093f17c97fbafac0537a6 (patch)
treefb3db563f7dde8a30198efaa1a68441324bd7958 /app-text/asciidoc
parentlibsmi keywording for ppc (diff)
downloadhistorical-0e53f9129a3ccc5a646093f17c97fbafac0537a6.tar.gz
historical-0e53f9129a3ccc5a646093f17c97fbafac0537a6.tar.bz2
historical-0e53f9129a3ccc5a646093f17c97fbafac0537a6.zip
Version bump, thank Alex Efros for report, bug #240355, also should fix bug #193966.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-openvz.git-777e816 i686
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/ChangeLog8
-rw-r--r--app-text/asciidoc/asciidoc-8.2.7.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/app-text/asciidoc/ChangeLog b/app-text/asciidoc/ChangeLog
index b13a20e5aa30..763f12179c92 100644
--- a/app-text/asciidoc/ChangeLog
+++ b/app-text/asciidoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/asciidoc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.39 2008/06/16 15:50:06 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.40 2008/10/18 14:11:49 pva Exp $
+
+*asciidoc-8.2.7 (18 Oct 2008)
+
+ 18 Oct 2008; Peter Volkov <pva@gentoo.org> +asciidoc-8.2.7.ebuild:
+ Version bump, thank Alex Efros for report, bug #240355, also should fix
+ bug #193966.
*asciidoc-8.2.6 (16 Jun 2008)
diff --git a/app-text/asciidoc/asciidoc-8.2.7.ebuild b/app-text/asciidoc/asciidoc-8.2.7.ebuild
new file mode 100644
index 000000000000..838b8af6e3c9
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-8.2.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/asciidoc-8.2.7.ebuild,v 1.1 2008/10/18 14:11:49 pva Exp $
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+SRC_URI="http://www.methods.co.nz/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples vim-syntax"
+
+DEPEND=">=virtual/python-2.4
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s:^BINDIR=.*:BINDIR=${D}usr/bin:" \
+ -e "s:^MANDIR=.*:MANDIR=${D}usr/share/man:" \
+ -e "s:^CONFDIR=.*:CONFDIR=${D}etc/asciidoc:" \
+ -e "s:^VIM_CONFDIR=.*:VIM_CONFDIR=${D}usr/share/vim/vimfiles:" \
+ "${S}/install.sh"
+}
+
+src_install() {
+ dodir /usr/bin
+
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ "${S}"/install.sh
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm -f examples/website/images
+ cp -Rf images examples/website
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ # HTML pages (with their sources)
+ dohtml -r doc/*
+ insinto /usr/share/doc/${PF}/html
+ doins doc/*.txt
+
+ # Misc. documentation
+ dodoc BUGS CHANGELOG README
+ dodoc docbook-xsl/asciidoc-docbook-xsl.txt
+}
+
+pkg_preinst() {
+ # Clean any symlinks in /etc possibly installed by previous versions
+ if [ -d "${ROOT}etc/asciidoc" ]; then
+ einfo "Cleaning old symlinks under /etc/asciidoc"
+ for entry in $(find "${ROOT}etc/asciidoc" -type l); do
+ rm -f $entry
+ done
+ fi
+}