summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2010-02-22 21:08:41 +0000
committerJonathan Callen <jcallen@gentoo.org>2010-02-22 21:08:41 +0000
commitb64af5be23fdbb3702c490cf149cbb5d3d0836e3 (patch)
tree5829457cee907d50a790351d78985f68502f2a45 /app-text/catdoc/catdoc-0.94.2-r1.ebuild
parentTransfer prefix keywords, bump EAPI (diff)
downloadhistorical-b64af5be23fdbb3702c490cf149cbb5d3d0836e3.tar.gz
historical-b64af5be23fdbb3702c490cf149cbb5d3d0836e3.tar.bz2
historical-b64af5be23fdbb3702c490cf149cbb5d3d0836e3.zip
Transfer prefix keywords, bump EAPI
Package-Manager: portage--svn/cvs/Linux i686
Diffstat (limited to 'app-text/catdoc/catdoc-0.94.2-r1.ebuild')
-rw-r--r--app-text/catdoc/catdoc-0.94.2-r1.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-text/catdoc/catdoc-0.94.2-r1.ebuild b/app-text/catdoc/catdoc-0.94.2-r1.ebuild
index 60e8ac94c16f..b16390b7d344 100644
--- a/app-text/catdoc/catdoc-0.94.2-r1.ebuild
+++ b/app-text/catdoc/catdoc-0.94.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/catdoc/catdoc-0.94.2-r1.ebuild,v 1.2 2009/06/09 12:39:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/catdoc/catdoc-0.94.2-r1.ebuild,v 1.3 2010/02/22 21:07:22 abcd Exp $
+EAPI=3
WANT_AUTOMAKE=none
inherit autotools eutils
@@ -19,30 +20,27 @@ DEPEND="tk? ( >=dev-lang/tk-8.1 )"
DOCS="CODING.STD CREDITS NEWS README TODO"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-flags.patch"
epatch "${FILESDIR}/${P}+autoconf-2.63.patch"
- eautoconf
-}
-src_compile() {
+ # Fix for case-insensitive filesystems
+ echo ".PHONY: all install clean distclean dist" >> Makefile.in
- local myconf="--with-install-root=${D}"
+ eautoconf
+}
- use tk \
- && myconf="${myconf} --with-wish=/usr/bin/wish" \
- || myconf="${myconf} --disable-wordview"
+src_configure() {
+ econf --with-install-root="${D}" \
+ $(use_with tk wish "${EPREFIX}"/usr/bin/wish) \
+ $(use_with !tk wordview)
+}
- econf ${myconf} || die
+src_compile() {
emake LIB_DIR=/usr/share/catdoc || die
-
}
src_install() {
-
- emake -j1 mandir=/usr/share/man/man1 install || die
+ emake -j1 mandir="${EPREFIX}"/usr/share/man/man1 install || die
dodoc ${DOCS}
-
}