summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-30 08:29:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-30 08:29:28 +0000
commit502727c5589d932a979f8877203947dc613cac0a (patch)
tree1e4442b4ae30a10bee5e6d058ac0120948012a6b /app-text/gmanedit
parentAdded multibyte support to ebuild (diff)
downloadhistorical-502727c5589d932a979f8877203947dc613cac0a.tar.gz
historical-502727c5589d932a979f8877203947dc613cac0a.tar.bz2
historical-502727c5589d932a979f8877203947dc613cac0a.zip
closes bug #2265
Diffstat (limited to 'app-text/gmanedit')
-rw-r--r--app-text/gmanedit/ChangeLog13
-rw-r--r--app-text/gmanedit/files/digest-gmanedit-0.3.3-r21
-rw-r--r--app-text/gmanedit/gmanedit-0.3.3-r2.ebuild30
3 files changed, 43 insertions, 1 deletions
diff --git a/app-text/gmanedit/ChangeLog b/app-text/gmanedit/ChangeLog
index ccefa26c970c..1ebaa996086f 100644
--- a/app-text/gmanedit/ChangeLog
+++ b/app-text/gmanedit/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-text/gmanedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/gmanedit/ChangeLog,v 1.1 2002/02/01 21:53:10 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gmanedit/ChangeLog,v 1.2 2002/04/30 08:29:28 seemant Exp $
+
+*gmanedit-0.3.3-r2 (30 Apr 2002)
+
+ 30 Apr 2002; Seemant Kulleen <seemant@gentoo.org> gmanedit-0.3.3-r2.ebuild
+ files/digest-gmanedit-0.3.3-r2 :
+
+ luke@dslextreme.com (Luke Ravitch) submitted a patch so that the configure
+ script can find gtk-config. Funny thing is this patch was just a reversal
+ of Hallski's original patch. So now, the configure script remains unpatched
+ and the DEPEND only needs gnome-libs not gnome-core. Also, general ebuild
+ cleanup.
*gmanedit-0.3.3-r1 (1 Feb 2002)
diff --git a/app-text/gmanedit/files/digest-gmanedit-0.3.3-r2 b/app-text/gmanedit/files/digest-gmanedit-0.3.3-r2
new file mode 100644
index 000000000000..63e33d30a72b
--- /dev/null
+++ b/app-text/gmanedit/files/digest-gmanedit-0.3.3-r2
@@ -0,0 +1 @@
+MD5 57c01c39d928f28644552e2b6491e390 gmanedit-0.3.3.tar.bz2 333208
diff --git a/app-text/gmanedit/gmanedit-0.3.3-r2.ebuild b/app-text/gmanedit/gmanedit-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..250b36e0b066
--- /dev/null
+++ b/app-text/gmanedit/gmanedit-0.3.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Tools Team <tools@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/gmanedit/gmanedit-0.3.3-r2.ebuild,v 1.1 2002/04/30 08:29:28 seemant Exp $
+
+S=${WORKDIR}/${P}.orig
+DESCRIPTION="Gnome based manpage editor"
+SRC_URI="http://gmanedit.sourceforge.net/files/${P}.tar.bz2"
+HOMEPAGE="http://gmanedit.sourceforge.net/"
+
+DEPEND="virtual/x11
+ >=gnome-base/gnome-libs-1.4.1.4"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog TODO README NEWS
+}