summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-14 16:07:44 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-14 16:07:44 +0000
commit93ff956bdf797d2c47ac2e8001580d4aa43a7457 (patch)
treea974744d7af75fb8a9ece60d42733013050d4d15 /app-text/gpdf/gpdf-0.112.1.ebuild
parentversion bump (diff)
downloadhistorical-93ff956bdf797d2c47ac2e8001580d4aa43a7457.tar.gz
historical-93ff956bdf797d2c47ac2e8001580d4aa43a7457.tar.bz2
historical-93ff956bdf797d2c47ac2e8001580d4aa43a7457.zip
version bump
Diffstat (limited to 'app-text/gpdf/gpdf-0.112.1.ebuild')
-rw-r--r--app-text/gpdf/gpdf-0.112.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/gpdf/gpdf-0.112.1.ebuild b/app-text/gpdf/gpdf-0.112.1.ebuild
new file mode 100644
index 000000000000..82e2d497bcb6
--- /dev/null
+++ b/app-text/gpdf/gpdf-0.112.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-0.112.1.ebuild,v 1.1 2004/02/14 16:07:44 liquidx Exp $
+
+inherit gnome2 flag-o-matic eutils
+
+DESCRIPTION="your favourite pdf previewer"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2.1
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.3
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS CHANGES ChangeLog COPYING INSTALL NEWS README*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${PN}-0.112-remove_gtk24_call.patch
+}
+
+src_compile() {
+ use alpha && append-flags -fPIC
+ gnome2_src_compile
+}