summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2009-08-01 18:07:24 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2009-08-01 18:07:24 +0000
commite301e294e0eda2df487da693cd1cbcf180a01215 (patch)
tree45eb97a5e2da2453e7f8e1cf928821b122103d82 /dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch
parentRemove kernel check for paravirt. No longer needed. Per bug #279701. (diff)
downloadhistorical-e301e294e0eda2df487da693cd1cbcf180a01215.tar.gz
historical-e301e294e0eda2df487da693cd1cbcf180a01215.tar.bz2
historical-e301e294e0eda2df487da693cd1cbcf180a01215.zip
Version bump, disabled fortran in testing for now - bug 279824.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch')
-rw-r--r--dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch b/dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch
new file mode 100644
index 000000000000..f4ac564cffd6
--- /dev/null
+++ b/dev-cpp/eigen/files/eigen-2.0.4-qt-test.patch
@@ -0,0 +1,34 @@
+# HG changeset patch -- Bitbucket.org
+# Project eigen2
+# URL http://bitbucket.org/cryos/eigen2/overview/
+# User Marcus D. Hanwell <marcus@cryos.org>
+# Date 1249148586 14400
+# Node ID 3c11267138fe98757d27308d2133d0182da740f3
+# Parent 3b8120f077865e2a072e10f5be33e1d942b83a06
+Improved quoting of tests when added to the build.
+
+This fixes an issue where multiple versions of the Qt libraries are
+available, if the Qt library variable is not quoted an error was
+generated as only the first part 'optimized' was used by the create test
+macro.
+
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -158,7 +158,7 @@ macro(ei_add_test testname)
+ string(STRIP "${ARGV2}" ARGV2_stripped)
+ string(LENGTH "${ARGV2_stripped}" ARGV2_stripped_length)
+ if(${ARGV2_stripped_length} GREATER 0)
+- target_link_libraries(${targetname} ${ARGV2})
++ target_link_libraries(${targetname} "${ARGV2}")
+ endif(${ARGV2_stripped_length} GREATER 0)
+ endif(${ARGC} GREATER 2)
+
+@@ -212,7 +212,7 @@ ei_add_test(alignedbox)
+ ei_add_test(regression)
+ ei_add_test(stdvector)
+ if(QT4_FOUND)
+- ei_add_test(qtvector " " ${QT_QTCORE_LIBRARY})
++ ei_add_test(qtvector " " "${QT_QTCORE_LIBRARY}")
+ endif(QT4_FOUND)
+ ei_add_test(sparse_vector)
+ ei_add_test(sparse_basic)