summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-29 12:22:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-29 12:22:31 +0000
commite271e1071d46a06f1c19b857f538b4b855ae3172 (patch)
treeaa0173e10f91f796c986c55e2d4291847d2d1897 /dev-db/cdb/cdb-0.75.ebuild
parentMarked as stable and added docs. (diff)
downloadhistorical-e271e1071d46a06f1c19b857f538b4b855ae3172.tar.gz
historical-e271e1071d46a06f1c19b857f538b4b855ae3172.tar.bz2
historical-e271e1071d46a06f1c19b857f538b4b855ae3172.zip
errno fix
Diffstat (limited to 'dev-db/cdb/cdb-0.75.ebuild')
-rw-r--r--dev-db/cdb/cdb-0.75.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-db/cdb/cdb-0.75.ebuild b/dev-db/cdb/cdb-0.75.ebuild
index a5865fcc255d..84ccc2099df7 100644
--- a/dev-db/cdb/cdb-0.75.ebuild
+++ b/dev-db/cdb/cdb-0.75.ebuild
@@ -1,18 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.5 2003/02/13 10:01:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.6 2003/03/29 12:22:31 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A fast, reliable, simple package for creating and reading constant databases"
SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
HOMEPAGE="http://cr.yp.to/cdb.html"
+
SLOT="0"
-# is this license correct?
LICENSE="as-is"
KEYWORDS="x86"
-DEPEND="sys-apps/tar sys-apps/gzip"
-RDEPEND="virtual/glibc"
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ sys-apps/tar
+ sys-apps/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-errno.diff
+}
src_compile() {
echo "gcc ${CFLAGS}" > conf-cc