summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-12 20:30:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-12 20:30:14 +0000
commit3843aeab82a32ac2d8a90eda5024f16f3f00f08a (patch)
treeb0f764a606a12dc539fd3e83fa82908cb9774421 /dev-db/dbmodel/dbmodel-0.3.ebuild
parentAdd prefix support and keywords, switch to EAPI=3 (approved by chainsaw) (diff)
downloadhistorical-3843aeab82a32ac2d8a90eda5024f16f3f00f08a.tar.gz
historical-3843aeab82a32ac2d8a90eda5024f16f3f00f08a.tar.bz2
historical-3843aeab82a32ac2d8a90eda5024f16f3f00f08a.zip
Add missing x11-libs/qt-svg dependency per bug #334943. Migrated to qt4-r2
Package-Manager: portage-2.2_rc78/cvs/Linux x86_64
Diffstat (limited to 'dev-db/dbmodel/dbmodel-0.3.ebuild')
-rw-r--r--dev-db/dbmodel/dbmodel-0.3.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-db/dbmodel/dbmodel-0.3.ebuild b/dev-db/dbmodel/dbmodel-0.3.ebuild
index d10b3433e671..b917691b541b 100644
--- a/dev-db/dbmodel/dbmodel-0.3.ebuild
+++ b/dev-db/dbmodel/dbmodel-0.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/dbmodel/dbmodel-0.3.ebuild,v 1.1 2010/06/26 14:32:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/dbmodel/dbmodel-0.3.ebuild,v 1.2 2010/09/12 20:30:14 hwoarang Exp $
EAPI="2"
-inherit qt4
+inherit qt4-r2
DESCRIPTION="Qt4 tool for drawing entity-relational diagrams"
HOMEPAGE="http://oxygene.sk/lukas/dbmodel/"
@@ -15,14 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="x11-libs/qt-gui:4[debug?]"
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-svg:4"
RDEPEND="${DEPEND}"
+DOCS="AUTHORS CHANGES"
+
src_configure() {
eqmake4 ${PN}.pro PREFIX=/usr
}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS CHANGES || die "dodoc failed"
-}