summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
commit94df94796a7dbd78a9728dac5ec3a8fb8020f68e (patch)
tree4169b4794ca4350a6c090309ad52ebbf14eaeae7 /dev-db/mysql/mysql-5.0.54.ebuild
parentCleanup of forgotten files, fixes bug 274865 (diff)
downloadhistorical-94df94796a7dbd78a9728dac5ec3a8fb8020f68e.tar.gz
historical-94df94796a7dbd78a9728dac5ec3a8fb8020f68e.tar.bz2
historical-94df94796a7dbd78a9728dac5ec3a8fb8020f68e.zip
Disable the SSL tests in all old 5.x ebuilds because the SSL certificates have expired now.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-db/mysql/mysql-5.0.54.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.54.ebuild30
1 files changed, 28 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-5.0.54.ebuild b/dev-db/mysql/mysql-5.0.54.ebuild
index 8de84e32a40a..bf2738bcf935 100644
--- a/dev-db/mysql/mysql-5.0.54.ebuild
+++ b/dev-db/mysql/mysql-5.0.54.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.13 2008/11/14 09:42:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.14 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20080124"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -55,6 +55,32 @@ src_test() {
mysql_disable_test \
"subselect" \
"Testcase needs tuning on x86 for oom condition"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# We run the test protocols seperately
make -j1 test-ns force=--force