summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-12 21:37:33 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-12 21:37:33 +0000
commite015889b5b42bee84fd757df5a1f0b1483885a5a (patch)
treea0c1f998332aa33e5103d12f8d9f5238d90b7913 /dev-db/octopus/octopus-3.0.1.ebuild
parentkeyword x86 (diff)
downloadhistorical-e015889b5b42bee84fd757df5a1f0b1483885a5a.tar.gz
historical-e015889b5b42bee84fd757df5a1f0b1483885a5a.tar.bz2
historical-e015889b5b42bee84fd757df5a1f0b1483885a5a.zip
Fix deps
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-db/octopus/octopus-3.0.1.ebuild')
-rw-r--r--dev-db/octopus/octopus-3.0.1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/dev-db/octopus/octopus-3.0.1.ebuild b/dev-db/octopus/octopus-3.0.1.ebuild
index abb3f2e2390a..f786f7765d47 100644
--- a/dev-db/octopus/octopus-3.0.1.ebuild
+++ b/dev-db/octopus/octopus-3.0.1.ebuild
@@ -1,32 +1,31 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1.ebuild,v 1.3 2005/06/08 19:32:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1.ebuild,v 1.4 2005/07/12 21:37:33 axxo Exp $
inherit java-pkg
MY_PV=${PV//./-}
MY_PV=${MY_PV/-/.}
-DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool. It
-may connect to any JDBC data sources and perform transformations defined in an
-XML file."
+DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool. It may connect to any JDBC data sources and perform transformations defined in an XML file."
SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-${MY_PV}.src.tar.gz
mirror://gentoo/${PN}-xmls-${PV}.tar.bz2"
HOMEPAGE="http://octopus.objectweb.org"
LICENSE="LGPL-2.1"
SLOT="3.0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 x86"
IUSE="doc jikes source"
-DEPEND=">=virtual/jdk-1.4
- jikes? ( >=dev-java/jikes-1.21 )
- source? ( app-arch/zip )
- >=dev-java/ant-core-1.4
- >=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jre-1.4
>=dev-java/xerces-2.6
>=dev-java/log4j-1.2.8
=dev-java/rhino-1.6*
>=dev-java/fop-0.20.5
>=dev-db/hsqldb-1.7.2.4"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jikes? ( >=dev-java/jikes-1.21 )
+ source? ( app-arch/zip )
+ >=dev-java/ant-core-1.4
+ >=app-arch/unzip-5.50-r1"
S=${WORKDIR}/${PN}-3.0/Octopus-src
@@ -50,7 +49,7 @@ src_compile() {
}
src_install() {
- dodoc ChangeLog.txt LICENSE.txt ReleaseNotes.txt
+ dodoc ChangeLog.txt ReleaseNotes.txt
cd ${S}/modules
java-pkg_dojar dist/*.jar