summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-12-07 17:58:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-12-07 17:58:33 +0000
commit93cf72996ca53b191723dfcf30a6cf712610e452 (patch)
tree8bfcf1ec41429908d3476e392c9a194909e45e97 /dev-db/pgadmin3/pgadmin3-1.10.1.ebuild
parentCleaning and added same trick for parallel build in 3.6.3 as in 4.0.1 (diff)
downloadhistorical-93cf72996ca53b191723dfcf30a6cf712610e452.tar.gz
historical-93cf72996ca53b191723dfcf30a6cf712610e452.tar.bz2
historical-93cf72996ca53b191723dfcf30a6cf712610e452.zip
Bump
Package-Manager: portage-2.2_rc56/cvs/Linux x86_64
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.10.1.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.10.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild
new file mode 100644
index 000000000000..de1b4cd0e988
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild,v 1.1 2009/12/07 17:58:33 patrick Exp $
+
+EAPI="1"
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8
+ virtual/postgresql-base
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/1.8.2-as_needed_ssl_detect_broken.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-wx-version=2.8 \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ chmod -R go-w "${D}/usr/share"
+}