summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-10-01 09:56:16 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-10-01 09:56:16 +0000
commit2a8ab9c31e24af61f405de9da4c28adca5528353 (patch)
tree5f3f374fc2cda34bac32abaaff39aa7a97f0a2d6 /dev-db/slony1
parent~amd64 (diff)
downloadhistorical-2a8ab9c31e24af61f405de9da4c28adca5528353.tar.gz
historical-2a8ab9c31e24af61f405de9da4c28adca5528353.tar.bz2
historical-2a8ab9c31e24af61f405de9da4c28adca5528353.zip
version bump.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/ChangeLog7
-rw-r--r--dev-db/slony1/Manifest4
-rw-r--r--dev-db/slony1/files/digest-slony1-1.1.11
-rw-r--r--dev-db/slony1/slony1-1.1.1.ebuild54
4 files changed, 64 insertions, 2 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index b6ee683a19d8..5ca37c1b9f5e 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/slony1
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.6 2005/07/13 15:17:20 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.7 2005/10/01 09:56:16 nakano Exp $
+
+*slony1-1.1.1 (01 Oct 2005)
+
+ 01 Oct 2005; Masatomo Nakano <nakano@gentoo.org> +slony1-1.1.1.ebuild:
+ Version bump.
*slony1-1.1.0-r1 (13 Jul 2005)
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
index 3b591c70c4bc..ec4c8752ec7f 100644
--- a/dev-db/slony1/Manifest
+++ b/dev-db/slony1/Manifest
@@ -1,6 +1,8 @@
MD5 b108e943e69751b3d108e6340a9e4802 slony1-1.1.0-r1.ebuild 1309
-MD5 676ee791e2001d4d42014e29f77d3c19 ChangeLog 1091
+MD5 14644b0a1b3cf2e8dc6bca1f557e3e28 ChangeLog 1210
+MD5 b96d5e28321dd0ac2595115f91bc81ee slony1-1.1.1.ebuild 1306
MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
+MD5 e3bee18eaeddd92bd69aa0cf6ed87830 files/digest-slony1-1.1.1 65
MD5 c2cc8353a0c2c29dbef6270a8d171456 files/slony1.conf 338
MD5 49cfd44cfeff125989087bd693197d3d files/slony1.init 707
MD5 6addf1df013f7a58d282b10d2ea18cfd files/digest-slony1-1.1.0-r1 66
diff --git a/dev-db/slony1/files/digest-slony1-1.1.1 b/dev-db/slony1/files/digest-slony1-1.1.1
new file mode 100644
index 000000000000..886b648cb6f7
--- /dev/null
+++ b/dev-db/slony1/files/digest-slony1-1.1.1
@@ -0,0 +1 @@
+MD5 3696818673f2e5405d1cef4a51c132b4 slony1-1.1.1.tar.bz2 687566
diff --git a/dev-db/slony1/slony1-1.1.1.ebuild b/dev-db/slony1/slony1-1.1.1.ebuild
new file mode 100644
index 000000000000..c19ba3eff364
--- /dev/null
+++ b/dev-db/slony1/slony1-1.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-1.1.1.ebuild,v 1.1 2005/10/01 09:56:16 nakano Exp $
+
+inherit eutils
+
+IUSE="perl"
+#IUSE="perl snmp"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://developer.postgresql.org/~wieck/slony1/download/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql
+ perl? ( dev-perl/DBD-Pg )"
+# snmp? ( >=net-analyzer/net-snmp-5.1 )
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/slony1_remove_jave.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+ # myconf="${myconf} $(use_with snmp netsnmp)"
+
+ econf ${myconf} || die
+ emake || die
+
+ if use perl ; then
+ cd ${S}/tools
+ emake || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd ${FILESDIR}/slony1.init slony1 || die
+ newconfd ${FILESDIR}/slony1.conf slony1 || die
+
+}