summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-09-19 10:17:27 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-09-19 10:17:27 +0000
commitec12055b5c43fdf10cc42460f805928bb4b44fe6 (patch)
tree7e681836975d9880749c4ba468d0e8064acd717b /dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild
parentVersion bump. Remove old ebuilds (diff)
downloadhistorical-ec12055b5c43fdf10cc42460f805928bb4b44fe6.tar.gz
historical-ec12055b5c43fdf10cc42460f805928bb4b44fe6.tar.bz2
historical-ec12055b5c43fdf10cc42460f805928bb4b44fe6.zip
Version bump, remove old versions. Thanks to David King <amigadave@amigadave.com> for reporting (bug #338019).
Package-Manager: portage-2.2_rc83/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild')
-rw-r--r--dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild b/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild
new file mode 100644
index 000000000000..07fe027dd93c
--- /dev/null
+++ b/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.18.ebuild,v 1.1 2010/09/19 10:17:27 ayoy Exp $
+
+ARMHARDV="hard-${PV}-4"
+ARMSOFTV="soft-${PV}-5"
+I486V="1.0.17-3"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-armv7-${ARMHARDV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-armv7-${ARMSOFTV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-i486-${I486V}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="=dev-embedded/scratchbox-1.0*"
+
+TARGET_DIR="/opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}