summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 15:47:05 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 15:47:05 +0000
commitba73ab7a4869a90abe54d88be92b1c2d0cce19e4 (patch)
treeecc45c60aaf76362569741bb06912207d0efa3c2 /dev-haskell/citeproc-hs
parentInitial version. Basic haskell implementation of the standard diff algorithm.... (diff)
downloadhistorical-ba73ab7a4869a90abe54d88be92b1c2d0cce19e4.tar.gz
historical-ba73ab7a4869a90abe54d88be92b1c2d0cce19e4.tar.bz2
historical-ba73ab7a4869a90abe54d88be92b1c2d0cce19e4.zip
Version bump.
Package-Manager: portage-2.2.0_alpha90_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/citeproc-hs')
-rw-r--r--dev-haskell/citeproc-hs/ChangeLog9
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.4.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-haskell/citeproc-hs/ChangeLog b/dev-haskell/citeproc-hs/ChangeLog
index f1fac996b833..964ba79e15ff 100644
--- a/dev-haskell/citeproc-hs/ChangeLog
+++ b/dev-haskell/citeproc-hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/citeproc-hs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/ChangeLog,v 1.1 2011/04/23 17:10:47 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/ChangeLog,v 1.2 2012/03/10 15:44:37 slyfox Exp $
+
+*citeproc-hs-0.3.4 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> +citeproc-hs-0.3.4.ebuild:
+ Version bump.
*citeproc-hs-0.3.2 (23 Apr 2011)
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.4.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.4.ebuild
new file mode 100644
index 000000000000..7e1bbe2027ef
--- /dev/null
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/citeproc-hs-0.3.4.ebuild,v 1.1 2012/03/10 15:44:37 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="A Citation Style Language implementation in Haskell"
+HOMEPAGE="http://gorgias.mine.nu/repos/citeproc-hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils +network"
+
+RDEPEND="dev-haskell/json[generic]
+ dev-haskell/mtl
+ >=dev-haskell/pandoc-types-1.8
+ dev-haskell/parsec
+ dev-haskell/time
+ dev-haskell/utf8-string
+ dev-haskell/xml
+ >=dev-lang/ghc-6.10.1
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3 )
+ network? ( >=dev-haskell/network-2
+ >=dev-haskell/http-4000.0.9
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"