summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:50:33 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:50:33 +0000
commit459f94804a203364afe4c42abb36c68d2d4fb2ea (patch)
treee00b22a80c2fb56561d252bb0b5ecf32c355f33b /dev-haskell/html
parentfix deps and checks (diff)
downloadhistorical-459f94804a203364afe4c42abb36c68d2d4fb2ea.tar.gz
historical-459f94804a203364afe4c42abb36c68d2d4fb2ea.tar.bz2
historical-459f94804a203364afe4c42abb36c68d2d4fb2ea.zip
Updates for upward compatability with cabal-1.2 and ghc-6.8
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/html')
-rw-r--r--dev-haskell/html/ChangeLog6
-rw-r--r--dev-haskell/html/html-1.0-r1.ebuild7
-rw-r--r--dev-haskell/html/html-1.0.1.ebuild5
3 files changed, 13 insertions, 5 deletions
diff --git a/dev-haskell/html/ChangeLog b/dev-haskell/html/ChangeLog
index 5264fd41cc5d..8b3c3eff25aa 100644
--- a/dev-haskell/html/ChangeLog
+++ b/dev-haskell/html/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/html
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/ChangeLog,v 1.23 2007/12/13 00:48:50 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/ChangeLog,v 1.24 2007/12/13 05:44:03 dcoutts Exp $
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> html-1.0-r1.ebuild,
+ html-1.0.1.ebuild:
+ Updates for upward compatability with cabal-1.2 and ghc-6.8
13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> html-1.0.ebuild:
Remove unnecessary blocker.
diff --git a/dev-haskell/html/html-1.0-r1.ebuild b/dev-haskell/html/html-1.0-r1.ebuild
index a7e2c1b1ef75..278a1b6dfb0d 100644
--- a/dev-haskell/html/html-1.0-r1.ebuild
+++ b/dev-haskell/html/html-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0-r1.ebuild,v 1.4 2007/07/08 15:36:36 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0-r1.ebuild,v 1.5 2007/12/13 05:44:03 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -19,3 +19,8 @@ IUSE=""
DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cabal-mksetup
+}
diff --git a/dev-haskell/html/html-1.0.1.ebuild b/dev-haskell/html/html-1.0.1.ebuild
index 90fdee49bbb9..019596adcb9f 100644
--- a/dev-haskell/html/html-1.0.1.ebuild
+++ b/dev-haskell/html/html-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0.1.ebuild,v 1.5 2007/12/12 13:50:54 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0.1.ebuild,v 1.6 2007/12/13 05:44:03 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -20,8 +20,7 @@ DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
-# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
unpack "${A}"
- sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
+ cabal-mksetup
}