summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-21 00:25:54 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-21 00:25:54 +0000
commite6497af3fa9fedc8d148c6d94d7cf5e48e3b4fb9 (patch)
treeeb8439cc42863785d8ab9baabc32c21798e108c3 /dev-java/ant-apache-bsf
parentAdd LDP-1 for man-pages-fr and others. (diff)
downloadhistorical-e6497af3fa9fedc8d148c6d94d7cf5e48e3b4fb9.tar.gz
historical-e6497af3fa9fedc8d148c6d94d7cf5e48e3b4fb9.tar.bz2
historical-e6497af3fa9fedc8d148c6d94d7cf5e48e3b4fb9.zip
Version bump, bug #305929.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-java/ant-apache-bsf')
-rw-r--r--dev-java/ant-apache-bsf/ChangeLog8
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild3
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild32
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-java/ant-apache-bsf/ChangeLog b/dev-java/ant-apache-bsf/ChangeLog
index 51dec7e8f9e1..d3ccdea55c15 100644
--- a/dev-java/ant-apache-bsf/ChangeLog
+++ b/dev-java/ant-apache-bsf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-apache-bsf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.26 2010/01/03 20:17:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.27 2010/02/21 00:21:08 caster Exp $
+
+*ant-apache-bsf-1.8.0 (20 Feb 2010)
+
+ 20 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ +ant-apache-bsf-1.8.0.ebuild:
+ Version bump, bug #305929.
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
ant-apache-bsf-1.7.1-r1.ebuild:
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
index 90905a300733..e8df467f3f7f 100644
--- a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild,v 1.6 2010/01/03 20:17:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild,v 1.7 2010/02/21 00:21:08 caster Exp $
EAPI=2
@@ -9,6 +9,7 @@ ANT_TASK_DEPNAME="bsf-2.3"
inherit eutils ant-tasks
KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
# ant-nodeps contains <script> task which is needed for this
# although it's not a build dep through import
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild
new file mode 100644
index 000000000000..df9c97ca5de3
--- /dev/null
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild,v 1.1 2010/02/21 00:21:08 caster Exp $
+
+EAPI=2
+
+ANT_TASK_DEPNAME="bsf-2.3"
+
+inherit eutils ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# ant-nodeps contains <script> task which is needed for this
+# although it's not a build dep through import
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
+RDEPEND="${DEPEND}
+ ~dev-java/ant-nodeps-${PV}"
+
+IUSE="python javascript tcl"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_install() {
+ ant-tasks_src_install
+ java-pkg_register-dependency ant-nodeps
+}
+
+pkg_postinst() {
+ elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
+ elog "ruby and beanshell. See its postinst elog messages for instructions."
+}