summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2012-02-18 22:14:16 +0000
committerVlastimil Babka <caster@gentoo.org>2012-02-18 22:14:16 +0000
commitf59caffd78733234ece237a8a6c0cbf6ab40f902 (patch)
tree90c7c655162356a4ab30cc14dba506ee274bc8b2 /dev-java/ant-testutil
parentAdd hppa and ppc KEYWORDS (#397195) (diff)
downloadhistorical-f59caffd78733234ece237a8a6c0cbf6ab40f902.tar.gz
historical-f59caffd78733234ece237a8a6c0cbf6ab40f902.tar.bz2
historical-f59caffd78733234ece237a8a6c0cbf6ab40f902.zip
Version bump, bug #351850.
Package-Manager: portage-2.2.0_alpha85/cvs/Linux x86_64
Diffstat (limited to 'dev-java/ant-testutil')
-rw-r--r--dev-java/ant-testutil/ChangeLog9
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.8.2.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-java/ant-testutil/ChangeLog b/dev-java/ant-testutil/ChangeLog
index d13fc49ed32f..ba188bf25502 100644
--- a/dev-java/ant-testutil/ChangeLog
+++ b/dev-java/ant-testutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-testutil
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.9 2011/12/31 11:23:53 sera Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.10 2012/02/18 22:13:46 caster Exp $
+
+*ant-testutil-1.8.2 (18 Feb 2012)
+
+ 18 Feb 2012; Vlastimil Babka <caster@gentoo.org> +ant-testutil-1.8.2.ebuild:
+ Version bump, bug #351850.
31 Dec 2011; Ralph Sennhauser <sera@gentoo.org> +ant-testutil-1.8.0.ebuild:
Restore 1.8.0 as there still are reverse dependencies, drop ia64 keyword
diff --git a/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild b/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild
new file mode 100644
index 000000000000..c999786bf25e
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.8.2.ebuild,v 1.1 2012/02/18 22:13:46 caster Exp $
+
+EAPI="4"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="virtual/jdk:1.6
+ dev-java/junit:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}"
+RDEPEND=""
+
+IUSE=""
+
+# the build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}