summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-16 00:30:50 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-16 00:30:50 +0000
commitcc94004d32ed38ad449210fb8ae228df67c31614 (patch)
tree2abaf98621e55882c66609f4f445f0b2e3e72594 /dev-java/blowfishj/blowfishj-2.14.ebuild
parentstable on amd64 and x86, added ~ppc (diff)
downloadhistorical-cc94004d32ed38ad449210fb8ae228df67c31614.tar.gz
historical-cc94004d32ed38ad449210fb8ae228df67c31614.tar.bz2
historical-cc94004d32ed38ad449210fb8ae228df67c31614.zip
stable on amd64, ppc and x86
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'dev-java/blowfishj/blowfishj-2.14.ebuild')
-rw-r--r--dev-java/blowfishj/blowfishj-2.14.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-java/blowfishj/blowfishj-2.14.ebuild b/dev-java/blowfishj/blowfishj-2.14.ebuild
index 07e5b76ddc7f..550905b7f19e 100644
--- a/dev-java/blowfishj/blowfishj-2.14.ebuild
+++ b/dev-java/blowfishj/blowfishj-2.14.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14.ebuild,v 1.1 2005/04/03 14:01:17 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14.ebuild,v 1.2 2005/05/16 00:30:50 luckyduck Exp $
inherit java-pkg
DESCRIPTION="Blowfish implementation in Java"
SRC_URI="mirror://sourceforge/blowfishj/${P}-src.tar.gz"
HOMEPAGE="http://blowfishj.sourceforge.net/index.html"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
IUSE="doc junit"
+
DEPEND=">=virtual/jre-1.4
- app-arch/unzip
- junit? ( dev-java/junit ) "
+ app-arch/unzip
+ junit? ( dev-java/junit ) "
RDEPEND=">=virtual/jre-1.4"
src_compile() {
local antflags="jar"
use doc && antflags="${antflags} javadoc"
use junit && antflags="${antflags} test"
-
ant ${antflags} || die "failed to compile"
}