summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-23 07:44:07 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-23 07:44:07 +0000
commitab807146d6783081755a19125fea0669a8f45c0e (patch)
tree319cbe9993cf6b332ced337c9ea76e560e187a18 /dev-java/constantine
parentVersion bump, thanks to chewi. (diff)
downloadhistorical-ab807146d6783081755a19125fea0669a8f45c0e.tar.gz
historical-ab807146d6783081755a19125fea0669a8f45c0e.tar.bz2
historical-ab807146d6783081755a19125fea0669a8f45c0e.zip
New package, jruby dependency. Ebuild provided by chewi in java-overlay.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-java/constantine')
-rw-r--r--dev-java/constantine/ChangeLog10
-rw-r--r--dev-java/constantine/constantine-0.5.ebuild34
-rw-r--r--dev-java/constantine/metadata.xml6
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/constantine/ChangeLog b/dev-java/constantine/ChangeLog
new file mode 100644
index 000000000000..950b38ad5ab1
--- /dev/null
+++ b/dev-java/constantine/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/constantine
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/constantine/ChangeLog,v 1.1 2009/05/23 07:38:01 caster Exp $
+
+*constantine-0.5 (22 May 2009)
+
+ 22 May 2009; Vlastimil Babka <caster@gentoo.org> +constantine-0.5.ebuild,
+ +metadata.xml:
+ New package, jruby dependency. Ebuild provided by chewi in java-overlay.
+
diff --git a/dev-java/constantine/constantine-0.5.ebuild b/dev-java/constantine/constantine-0.5.ebuild
new file mode 100644
index 000000000000..a89eda93aae9
--- /dev/null
+++ b/dev-java/constantine/constantine-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/constantine/constantine-0.5.ebuild,v 1.1 2009/05/23 07:38:01 caster Exp $
+
+JAVA_PKG_IUSE="source test"
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides Java values for common platform C constants"
+HOMEPAGE="http://kenai.com/projects/constantine"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit4 )"
+
+src_compile() {
+ # ecj doesn't like some cast for some reason
+ java-pkg_force-compiler javac
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use source && java-pkg_dosrc src/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test -Dlibs.junit_4.classpath="$(java-pkg_getjars --with-dependencies junit-4)"
+}
diff --git a/dev-java/constantine/metadata.xml b/dev-java/constantine/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/constantine/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+