summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-30 19:41:40 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-30 19:41:40 +0000
commitedecf9c4e3d076c89b5672d7db9d3fe660390b90 (patch)
tree528a439b461847ec7e628fcce35adc77725e83a1 /dev-java/dbunit-bin/dbunit-bin-2.0.ebuild
parentmove dev-java/dbunit dev-java/dbunit-bin (diff)
downloadhistorical-edecf9c4e3d076c89b5672d7db9d3fe660390b90.tar.gz
historical-edecf9c4e3d076c89b5672d7db9d3fe660390b90.tar.bz2
historical-edecf9c4e3d076c89b5672d7db9d3fe660390b90.zip
move dev-java/dbunit dev-java/dbunit-bin
Diffstat (limited to 'dev-java/dbunit-bin/dbunit-bin-2.0.ebuild')
-rw-r--r--dev-java/dbunit-bin/dbunit-bin-2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/dbunit-bin/dbunit-bin-2.0.ebuild b/dev-java/dbunit-bin/dbunit-bin-2.0.ebuild
new file mode 100644
index 000000000000..50638136aa20
--- /dev/null
+++ b/dev-java/dbunit-bin/dbunit-bin-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit-bin/dbunit-bin-2.0.ebuild,v 1.1 2004/07/30 19:40:43 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="DBUnit is a JUnit extension targeted for database-driven projects that, puts your database into a known state between test runs."
+SRC_URI="mirror://sourceforge/${PN}/${P/-bin}.zip"
+HOMEPAGE="http://www.dbunit.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jdk-1.3"
+IUSE="doc"
+
+src_compile() { :; }
+
+src_install() {
+ mv ${S}/${P/-bin}.jar ${S}/${PN}.jar
+ java-pkg_dojar ${PN}.jar
+ use doc && dohtml -r docs/*
+}