summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-07 16:04:07 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-07 16:04:07 +0000
commitf718432ddbcb92fca840cebf2cfa3efc6d1538d2 (patch)
tree537ae6f5c0bedb1f94a4c808898abf32bccda3e0 /dev-java/joda-time
parentAdd missing bump entry in changelog, thanks armin76. (diff)
downloadhistorical-f718432ddbcb92fca840cebf2cfa3efc6d1538d2.tar.gz
historical-f718432ddbcb92fca840cebf2cfa3efc6d1538d2.tar.bz2
historical-f718432ddbcb92fca840cebf2cfa3efc6d1538d2.zip
Revbump to migrate to split-ant; improve style; add examples flag. Restrict tests to 1.4 jdk, but they still like to fail.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'dev-java/joda-time')
-rw-r--r--dev-java/joda-time/ChangeLog8
-rw-r--r--dev-java/joda-time/files/digest-joda-time-1.4-r13
-rw-r--r--dev-java/joda-time/joda-time-1.4-r1.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-java/joda-time/ChangeLog b/dev-java/joda-time/ChangeLog
index 9b71cedf6412..b71918d15c88 100644
--- a/dev-java/joda-time/ChangeLog
+++ b/dev-java/joda-time/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/joda-time
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.23 2007/03/11 00:04:31 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.24 2007/05/07 16:04:07 caster Exp $
+
+*joda-time-1.4-r1 (07 May 2007)
+
+ 07 May 2007; Vlastimil Babka <caster@gentoo.org> +joda-time-1.4-r1.ebuild:
+ Revbump to migrate to split-ant; improve style; add examples flag. Restrict
+ tests to 1.4 jdk, but they still like to fail.
11 Mar 2007; Petteri Räty <betelgeuse@gentoo.org> -joda-time-1.3.ebuild:
Remove old version that is not optimal with the DST changes.
diff --git a/dev-java/joda-time/files/digest-joda-time-1.4-r1 b/dev-java/joda-time/files/digest-joda-time-1.4-r1
new file mode 100644
index 000000000000..12232760fbde
--- /dev/null
+++ b/dev-java/joda-time/files/digest-joda-time-1.4-r1
@@ -0,0 +1,3 @@
+MD5 44997ed94a92f85c6e70ef02cfae2f5d joda-time-1.4-src.tar.gz 1206046
+RMD160 68cd218a762cc55e5477ddc61077f83b402bf2d0 joda-time-1.4-src.tar.gz 1206046
+SHA256 31b4c1a3a3ff1742d41b5b5ec69fe1b84f38cd383bdb214fe0e07fc870b47a40 joda-time-1.4-src.tar.gz 1206046
diff --git a/dev-java/joda-time/joda-time-1.4-r1.ebuild b/dev-java/joda-time/joda-time-1.4-r1.ebuild
new file mode 100644
index 000000000000..5c00b90bf6bc
--- /dev/null
+++ b/dev-java/joda-time/joda-time-1.4-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/joda-time-1.4-r1.ebuild,v 1.1 2007/05/07 16:04:07 caster Exp $
+
+JAVA_PKG_IUSE="doc examples source test"
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes."
+HOMEPAGE="http://joda-time.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="
+ elibc_glibc? ( >=sys-libs/timezone-data-2007c )
+"
+# test fail compile with 1.5+ because test mock object doesn't override some
+# new abstract foo
+DEPEND="
+ test? (
+ =dev-java/junit-3*
+ dev-java/ant-junit
+ =virtual/jdk-1.4*
+ )
+ !test? ( >=virtual/jdk-1.4 )
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v ${P}.jar || die
+}
+
+src_compile() {
+ # chokes on static inner class making instance of non-static inner class
+ java-pkg_filter-compiler jikes
+ # little trick so it doesn't try to download junit
+ eant -Djunit.ant=1 -Djunit.present=1 jar $(use_doc)
+}
+
+src_test() {
+ if has_version "<sys-libs/timezone-data-2007c"; then
+ ewarn "Tests are known to fail with older versions of"
+ ewarn "sys-libs/timezone-data. Please update to the latest stable"
+ ewarn "version. We don't force it because not all libc"
+ ewarn "implementations use that package. See bugzilla for details:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=170189"
+ fi
+
+ ANT_TASKS="ant-junit" eant -Djunit.jar="$(java-pkg_getjars junit)" test
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar
+
+ dodoc LICENSE.txt NOTICE.txt RELEASE-NOTES.txt ToDo.txt || die
+ use doc && java-pkg_dojavadoc build/docs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/java/org
+}