summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-16 22:26:23 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-16 22:26:23 +0000
commite5a8ca594e420454ef00f842bb21c71808de64b0 (patch)
tree4599b6e44b92496a3ac47b304b117b067a9bedc4 /dev-java/qat/qat-2.7.1-r1.ebuild
parentfix cross-compiling logic #92694 (diff)
downloadhistorical-e5a8ca594e420454ef00f842bb21c71808de64b0.tar.gz
historical-e5a8ca594e420454ef00f842bb21c71808de64b0.tar.bz2
historical-e5a8ca594e420454ef00f842bb21c71808de64b0.zip
stable on amd64, ppc and x86. introduced support for the examples and for the jikes useflag
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-java/qat/qat-2.7.1-r1.ebuild')
-rw-r--r--dev-java/qat/qat-2.7.1-r1.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-java/qat/qat-2.7.1-r1.ebuild b/dev-java/qat/qat-2.7.1-r1.ebuild
index c15cfa44fc41..58fdd70bf284 100644
--- a/dev-java/qat/qat-2.7.1-r1.ebuild
+++ b/dev-java/qat/qat-2.7.1-r1.ebuild
@@ -1,21 +1,24 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qat/qat-2.7.1-r1.ebuild,v 1.4 2004/11/03 11:37:08 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qat/qat-2.7.1-r1.ebuild,v 1.5 2005/05/16 22:26:23 luckyduck Exp $
inherit java-pkg
DESCRIPTION="Quality Assurance Tester - A distributed test harnass."
SRC_URI="mirror://sourceforge/qat/qat-${PV}-src.zip"
HOMEPAGE="http://qat.sourceforge.net"
+
LICENSE="sun-csl"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+KEYWORDS="x86 ~sparc ppc amd64"
+IUSE="doc examples jikes"
+
DEPEND=">=virtual/jdk-1.3
- app-arch/unzip"
+ app-arch/unzip
+ jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.3
- dev-java/jlfgr
- dev-java/junit"
-IUSE="doc"
+ dev-java/jlfgr
+ dev-java/junit"
S=${WORKDIR}
@@ -28,7 +31,9 @@ src_unpack() {
}
src_compile() {
- ant jar || die "failed to build"
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "failed to build"
}
src_install() {
@@ -40,6 +45,10 @@ src_install() {
dobin ${PN}
- use doc && java-pkg_dohtml -r doc/* && dohtml -r specification/* && cp -R examples ${D}/usr/share/doc/${P}/
+ use doc && java-pkg_dohtml -r doc/* && java-pkg_dohtml -r specification/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -R examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
}