summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-06-17 10:45:08 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-06-17 10:45:08 +0000
commit5c7d1d9c17caee780b759269ecf33211386df849 (patch)
treea4fe8f3078d23e2e07664c0a8d975a54935c13cf /dev-java/rhino
parentQA - inherit eutils, don't assign default S. (diff)
downloadhistorical-5c7d1d9c17caee780b759269ecf33211386df849.tar.gz
historical-5c7d1d9c17caee780b759269ecf33211386df849.tar.bz2
historical-5c7d1d9c17caee780b759269ecf33211386df849.zip
Fixed up the proxy problem with a rather dirty sed script. It should work. Do tell me if it does not.
Diffstat (limited to 'dev-java/rhino')
-rw-r--r--dev-java/rhino/Manifest4
-rw-r--r--dev-java/rhino/rhino-1.5-r5.ebuild8
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-java/rhino/Manifest b/dev-java/rhino/Manifest
index dd8f7afa79a7..4f6625ecf827 100644
--- a/dev-java/rhino/Manifest
+++ b/dev-java/rhino/Manifest
@@ -1,5 +1,5 @@
+MD5 b48ecb4144a4ca9bff32d491c6688bbc rhino-1.5-r5.ebuild 1365
MD5 907b0ce974f3f2a0f73006dfea8ee59b ChangeLog 1432
MD5 4622606981d4aa0930c917b65cf2f202 metadata.xml 350
-MD5 aa8f6ab2c75282604f46cabcfd186163 rhino-1.5-r5.ebuild 1016
-MD5 c663f3b82777d7ee2506dc0a03955198 files/jsscript 123
MD5 2f216cc7ea2b6e2b8356aa3a1fee7c14 files/digest-rhino-1.5-r5 60
+MD5 c663f3b82777d7ee2506dc0a03955198 files/jsscript 123
diff --git a/dev-java/rhino/rhino-1.5-r5.ebuild b/dev-java/rhino/rhino-1.5-r5.ebuild
index 739233408d48..e7e2f27dcbe7 100644
--- a/dev-java/rhino/rhino-1.5-r5.ebuild
+++ b/dev-java/rhino/rhino-1.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.3 2004/05/09 22:04:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.4 2004/06/17 10:45:08 st_lim Exp $
inherit java-pkg
@@ -21,6 +21,12 @@ RESTRICT="nomirror"
src_compile() {
local antflags="jar"
+
+ [ -n $http_proxy ] && proxyhost=`echo $http_proxy | sed -e "s/^\(.*\):\([0-9]*\)/\1/g" ` && \
+ proxyport=`echo $http_proxy | sed -e "s/^\(.*\):\([0-9]*\)/\2/g" ` && \
+ sed -e "s:<target name=\"get-swing-ex\" unless=\"swing-ex-available\">:&\n<setproxy proxyhost=\"${proxyhost}\" proxyport=\"${proxyport}\" />:g" \
+ -i toolsrc/build.xml
+
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compilation error"
}