summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-06-09 21:04:10 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-06-09 21:04:10 +0000
commitcb0e2ef9bf9aadca6b80651ed7c33f8a80ec4727 (patch)
tree708d9b2652aa1ae77533187172b23d87ac41f1d2 /dev-lang/fpc-ide
parentProtoize is removed in 4.5. Bug #270558. (diff)
downloadhistorical-cb0e2ef9bf9aadca6b80651ed7c33f8a80ec4727.tar.gz
historical-cb0e2ef9bf9aadca6b80651ed7c33f8a80ec4727.tar.bz2
historical-cb0e2ef9bf9aadca6b80651ed7c33f8a80ec4727.zip
fpc: Install HTML documentation for fpc-ide; fpc/fpc-ide/lazarus: use clean fpc configuration and drop warnings about fpc.cfg
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'dev-lang/fpc-ide')
-rw-r--r--dev-lang/fpc-ide/ChangeLog5
-rw-r--r--dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild16
2 files changed, 19 insertions, 2 deletions
diff --git a/dev-lang/fpc-ide/ChangeLog b/dev-lang/fpc-ide/ChangeLog
index 45b83b0137ef..e2247d102d6a 100644
--- a/dev-lang/fpc-ide/ChangeLog
+++ b/dev-lang/fpc-ide/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/fpc-ide
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.13 2009/04/23 21:05:02 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.14 2009/06/09 21:04:09 truedfx Exp $
+
+ 09 Jun 2009; Harald van Dijk <truedfx@gentoo.org> fpc-ide-2.2.4.ebuild:
+ Build with clean fpc config, add note about documentation
*fpc-ide-2.2.4 (23 Apr 2009)
diff --git a/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild b/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild
index 0cf4dd53f96c..be1e339f05b2 100644
--- a/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild
+++ b/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild,v 1.1 2009/04/23 21:05:02 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.2.4.ebuild,v 1.2 2009/06/09 21:04:09 truedfx Exp $
S="${WORKDIR}/fpcbuild-${PV}/fpcsrc/ide"
@@ -14,11 +14,20 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
DEPEND="~dev-lang/fpc-${PV}"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A} || die "Unpacking ${A} failed!"
find "${WORKDIR}" -name Makefile -exec sed -i -e 's/ -Xs / /g' {} + || die
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set}; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ /usr/lib/fpc/${FPCVER}/samplecfg /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
}
src_compile() {
@@ -28,3 +37,8 @@ src_compile() {
src_install() {
emake -j1 INSTALL_PREFIX="${D}"usr install || die "make install failed"
}
+
+pkg_postinst() {
+ einfo "To read the documentation, enable the doc USE flag for dev-lang/fpc,"
+ einfo "and add /usr/share/doc/fpc-${PV}/fpctoc.htx to the Help Files list."
+}