summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-03-14 07:41:29 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-03-14 07:41:29 +0000
commit5eb940619dfa16ce9c5dbb839ab86fd06210fe6b (patch)
tree44a2a8c199dc6e062f3f83a057774dd9e9d66351 /dev-lang/ghc
parentversion bump (diff)
downloadhistorical-5eb940619dfa16ce9c5dbb839ab86fd06210fe6b.tar.gz
historical-5eb940619dfa16ce9c5dbb839ab86fd06210fe6b.tar.bz2
historical-5eb940619dfa16ce9c5dbb839ab86fd06210fe6b.zip
fix for the situation when ghc is being bootstrapped off different version
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/ghc-5.04.2.ebuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index e14823fbaee6..1c366270bf1a 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.10 2003/03/08 23:21:18 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.11 2003/03/14 07:41:29 george Exp $
+
+ 13 Mar 2003; George Shapovalov <george@gentoo.org> ghc-5.04.2.ebuild :
+ fix for when ghc gets bootstrapped off different version.
+ Thanks to Andres Loeh <andres@cs.uu.nl> and Ralf Hinze <ralf@informatik.uni-bonn.de>.
08 Mar 2003; George Shapovalov <george@gentoo.org> ghc-5.04.2.ebuild :
diff --git a/dev-lang/ghc/ghc-5.04.2.ebuild b/dev-lang/ghc/ghc-5.04.2.ebuild
index 7d2cd24dd2b0..3495552df41b 100644
--- a/dev-lang/ghc/ghc-5.04.2.ebuild
+++ b/dev-lang/ghc/ghc-5.04.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.2.ebuild,v 1.4 2003/03/11 21:11:45 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.2.ebuild,v 1.5 2003/03/14 07:41:29 george Exp $
#Some explanation of bootstrap logic:
#
@@ -107,15 +107,15 @@ src_compile() {
local myconf
use opengl && myconf="--enable-hopengl" || myconf="--disable-hopengl"
- if test x$need_stage2 = xyes; then
+ if test x$need_stage1 = xyes; then
echo ">>> Bootstrapping intermediate GHC ${PV} using GHC ${BASE_GHC_VERSION}"
pushd "${STAGE1_B}" || die
./configure \
-host="${CHOST}" \
- --prefix="${STAGE2_D}/usr" \
+ --prefix="${STAGE1_D}/usr" \
--with-ghc="${GHC}" \
- --without-happy || die "intermediat stage configure failed"
+ --without-happy || die "intermediate stage configure failed"
#parallel make causes trouble
make || die "intermediate stage make failed"
make install || die
@@ -132,10 +132,12 @@ src_compile() {
}
src_install () {
- make install \
- prefix="${D}/usr" \
- infodir="${D}/usr/share/info" \
- mandir="${D}/usr/share/man" || die
+ pushd "${STAGE2_B}" || die
+ make install \
+ prefix="${D}/usr" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" || die
+ popd
#need to remove ${D} from ghcprof script
cd ${D}/usr/bin