summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-10-14 05:08:12 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-10-14 05:08:12 +0000
commit6f55d3228e001956a541634a03d3085c48f21cfc (patch)
tree1bb92e433ce817272f07238cf3840acef8fb6600 /dev-lang/icc
parentnew 7.1.030 (diff)
downloadhistorical-6f55d3228e001956a541634a03d3085c48f21cfc.tar.gz
historical-6f55d3228e001956a541634a03d3085c48f21cfc.tar.bz2
historical-6f55d3228e001956a541634a03d3085c48f21cfc.zip
new 7.1.030
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/Manifest6
-rw-r--r--dev-lang/icc/files/digest-icc-7.1.0301
-rw-r--r--dev-lang/icc/icc-7.1.029.ebuild8
-rw-r--r--dev-lang/icc/icc-7.1.030.ebuild128
4 files changed, 136 insertions, 7 deletions
diff --git a/dev-lang/icc/Manifest b/dev-lang/icc/Manifest
index 67260964a968..b0b080adcc86 100644
--- a/dev-lang/icc/Manifest
+++ b/dev-lang/icc/Manifest
@@ -1,10 +1,10 @@
-MD5 bcaad67983a7ae54eec4179775a2c4ba icc-7.1.029.ebuild 3788
+MD5 ccd677c4921873c05964b44ba41f9911 icc-7.1.029.ebuild 3795
MD5 9d24368640b754755be7c13c1d8c0179 icc-7.1.006.ebuild 3733
MD5 356256656e0df2db03b5f36673f1b0ff icc-6.0-r1.ebuild 3135
MD5 ba482af3531a84aeaccd6c1e54a842cf icc-7.0.065-r1.ebuild 3230
-MD5 d75df54fcc91de517b27ecf1a1741b3a icc-7.1.030.ebuild 3790
+MD5 91a6f67bf8de1c5679fe362d6488d651 icc-7.1.030.ebuild 3850
MD5 75845f8c8389441c8d7c6f2d80d7ca1b icc-6.0.ebuild 2936
-MD5 76a7c0425997c2541aaf16e41a417a91 ChangeLog 3636
+MD5 4adcec8ed61c99d29663953e19540a06 ChangeLog 3825
MD5 13e8ac1fb111e241dfd6d934ef305abd metadata.xml 313
MD5 8267a3baf3fc2b1813c82c008f61634d icc-7.0.065-r2.ebuild 3230
MD5 13a5fd0e0298651c759d69aaa769acd7 icc-7.0.065.ebuild 3177
diff --git a/dev-lang/icc/files/digest-icc-7.1.030 b/dev-lang/icc/files/digest-icc-7.1.030
new file mode 100644
index 000000000000..54d11d9ba37a
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-7.1.030
@@ -0,0 +1 @@
+MD5 7124e0ab49d8908d47150ce95617d7ce l_cc_pc_7.1.030.tar 76042240
diff --git a/dev-lang/icc/icc-7.1.029.ebuild b/dev-lang/icc/icc-7.1.029.ebuild
index 5c014e02eda8..c0061f308820 100644
--- a/dev-lang/icc/icc-7.1.029.ebuild
+++ b/dev-lang/icc/icc-7.1.029.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.029.ebuild,v 1.3 2003/09/19 00:25:55 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.029.ebuild,v 1.4 2003/10/14 05:08:09 drobbins Exp $
inherit rpm
@@ -8,8 +8,8 @@ S=${WORKDIR}
DESCRIPTION="Intel C++ Compiler - Intel's Pentium optimized compiler for Linux"
-SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_p_${PV}.tar"
-SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_p_${PV}.tar"
+SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_pc_${PV}.tar"
+SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_pc_${PV}.tar"
SRC_URI="${SRC_URI1} ${SRC_URI2}"
HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
@@ -23,7 +23,7 @@ RDEPEND="virtual/linux-sources
>=sys-libs/glibc-2.2.5"
SLOT="7"
-KEYWORDS="-* ia64 x86"
+KEYWORDS="-* ~ia64 ~x86"
IUSE=""
RESTRICT="nostrip"
diff --git a/dev-lang/icc/icc-7.1.030.ebuild b/dev-lang/icc/icc-7.1.030.ebuild
new file mode 100644
index 000000000000..7437bad8d112
--- /dev/null
+++ b/dev-lang/icc/icc-7.1.030.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.030.ebuild,v 1.1 2003/10/14 05:08:09 drobbins Exp $
+
+inherit rpm
+
+S=${WORKDIR}
+#what dir to use in FILESDIR
+FILESV=7.1.029
+DESCRIPTION="Intel C++ Compiler - Intel's Pentium optimized compiler for Linux"
+
+SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_pc_${PV}.tar"
+SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_pc_${PV}.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+LICENSE="icc-7.0"
+
+DEPEND="virtual/linux-sources
+ >=sys-libs/glibc-2.2.5"
+
+RDEPEND="virtual/linux-sources
+ >=sys-libs/glibc-2.2.5"
+
+SLOT="7"
+KEYWORDS="-* ~ia64 ~x86"
+IUSE=""
+
+RESTRICT="nostrip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Keep disk space to a minimum
+ if [ "$ARCH" = "x86" ]
+ then
+ rm -f intel-*.ia64.rpm
+ else
+ rm -f intel-*.i386.rpm
+ fi
+
+ rpm_unpack *.rpm
+
+}
+src_compile() {
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler*/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ for SUPPORTFILE in ${SD}/compiler*/docs/*support
+ do
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+ done
+
+ # these should not be executable
+ find "${SD}/compiler70/"{docs,man,training,ia32/include} -type f -exec chmod -x "{}" ";"
+ find "${SD}/compiler70/ia32/lib" -name \*.a -exec chmod -x "{}" ";"
+
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ insinto /etc/env.d
+ if [ "$ARCH" = "x86" ]
+ then
+ newins ${FILESDIR}/${FILESV}/05icc-ifc-ia32 05icc-ifc || die
+ # fix the processor name issue with the primary icc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ newexe ${FILESDIR}/${FILESV}/icc-ia32 icc
+ newexe ${FILESDIR}/${FILESV}/icpc-ia32 icc
+ else
+ newins ${FILESDIR}/${FILESV}/05icc-ifc-ia64 05icc-ifc || die
+ dodir /usr/bin
+ dosym ../../opt/intel/compiler70/ia64/bin/eccbin /usr/bin/ecc
+ dosym ../../opt/intel/compiler70/ia64/bin/ecpcbin /usr/bin/ecpc
+ fi
+
+
+}
+
+pkg_postinst () {
+ einfo "The ICC compiler for Itanium systems is called \"ecc\"."
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+
+ ewarn
+ ewarn "Packages compiled with versions of icc older than 7.0 will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ ewarn "BEFORE COMPILING IMPORTANT APPLICATIONS THAT YOUR"
+ ewarn "SYSTEM DEPENDS ON, READ THE WARNING ABOVE."
+ ewarn "THIS COULD RENDER YOUR SYSTEM UNUSABLE."
+ ewarn "THIS IS A PROBLEM WITH INTEL'S SOFTWARE, _NOT_"
+ ewarn "WITH GENTOO."
+
+ ewarn "If 'icc' breaks, use 'iccbin' instead and report a bug."
+ ewarn "Please use 'source /etc/profile' prior to merging any icc-enabled"
+ ewarn "ebuilds."
+}