summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:44:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:44:55 +0000
commitd36dc6ba5357b429cd7bf8ad76a9bbbec213360d (patch)
tree3353867e0a0b478c2aefb7851da3047045eeb2b3 /dev-lang/icon
parentbeautified (diff)
downloadhistorical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.tar.gz
historical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.tar.bz2
historical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.zip
modernised
Diffstat (limited to 'dev-lang/icon')
-rw-r--r--dev-lang/icon/icon-9.40.ebuild82
1 files changed, 41 insertions, 41 deletions
diff --git a/dev-lang/icon/icon-9.40.ebuild b/dev-lang/icon/icon-9.40.ebuild
index c415024b55cb..91dcc20b33cb 100644
--- a/dev-lang/icon/icon-9.40.ebuild
+++ b/dev-lang/icon/icon-9.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.5 2002/08/01 11:40:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.6 2002/08/02 04:44:53 seemant Exp $
S=${WORKDIR}/icon.v940src
SRC_URI="http://www.cs.arizona.edu/icon/ftp/packages/unix/icon.v940src.tgz"
@@ -16,52 +16,52 @@ SLOT="0"
KEYWORDS="x86"
src_unpack() {
-
- cd ${WORKDIR}
- unpack ${A}
- cd ${S}/config/unix/intel_linux
- patch -p0 <${FILESDIR}/${P}-gentoo.diff
-
+
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}/config/unix/intel_linux
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff
+
}
src_compile() {
-
- cd ${S}
+
+ cd ${S}
- if [ "`use X`" ]; then
- try make X-Configure name=intel_linux
- else
- try make Configure name=intel_linux
- fi
-
- try make
-
- # small builtin test
- try make Samples
- # large builtin test
- try make Test
+ if [ "`use X`" ]; then
+ make X-Configure name=intel_linux || die
+ else
+ make Configure name=intel_linux || die
+ fi
+
+ make || die
+
+ # small builtin test
+ make Samples || die
+ # large builtin test
+ make Test || die
}
src_install () {
-
- #try make Install dest=${D}/opt/icon
- # fhs-problems, manual rectify
-
- into /usr
-
- cd ${S}/bin
- rm .placeholder libXpm.a rt.h
- dobin *
-
- cd ${S}/lib
- rm .placeholder
- dolib *
-
- cd ${S}/man/man1
- doman icont.1
-
- cd ${S}/doc
- dodoc * ../README
-
+
+ #make Install dest=${D}/opt/icon || die
+ # fhs-problems, manual rectify
+
+ into /usr
+
+ cd ${S}/bin
+ rm .placeholder libXpm.a rt.h
+ dobin *
+
+ cd ${S}/lib
+ rm .placeholder
+ dolib *
+
+ cd ${S}/man/man1
+ doman icont.1
+
+ cd ${S}/doc
+ dodoc * ../README
+
}