summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-10-14 10:44:03 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-10-14 10:44:03 +0000
commita582fad507176be8218a2f4b5b4465541ea01414 (patch)
tree401ec4fbd9b2eada74aaad33a0ade2cdbbd89ac5 /dev-lang/lua/lua-5.0.3.ebuild
parentFix econf call for non-autotools configure, fix quoting, remove pregenerated ... (diff)
downloadhistorical-a582fad507176be8218a2f4b5b4465541ea01414.tar.gz
historical-a582fad507176be8218a2f4b5b4465541ea01414.tar.bz2
historical-a582fad507176be8218a2f4b5b4465541ea01414.zip
Fix patch for as-needed, see comment #7 in bug #122128. Remove useless -l
directives when using readline. Package-Manager: portage-2.1.2_pre3
Diffstat (limited to 'dev-lang/lua/lua-5.0.3.ebuild')
-rw-r--r--dev-lang/lua/lua-5.0.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/lua/lua-5.0.3.ebuild b/dev-lang/lua/lua-5.0.3.ebuild
index b9882cf7ad23..5a988b096356 100644
--- a/dev-lang/lua/lua-5.0.3.ebuild
+++ b/dev-lang/lua/lua-5.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.3.ebuild,v 1.2 2006/10/07 15:42:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.3.ebuild,v 1.3 2006/10/14 10:44:03 exg Exp $
inherit eutils portability
@@ -43,7 +43,7 @@ src_unpack() {
if use readline ; then
sed -i config \
-e "s:^#\(USERCONF=-DLUA_USERCONFIG='\"\$(LUA)/etc/saconfig.c\"' -DUSE_READLINE\):\1:" \
- -e 's:^#\(EXTRA_LIBS= -lm -ldl -lreadline\) # \(-lhistory -lcurses -lncurses\):\1 \2:'
+ -e 's:^\(EXTRA_LIBS= -lm\)$:\1 -lreadline:'
fi
cat >etc/lua.pc <<EOF