summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:33:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:33:15 +0000
commit31d1807f04b02ee5efe3d00e5190ffc43ed32250 (patch)
treef5efba666f55322e628a27afe4316425e9306470 /dev-lang/lua
parentadd inherit eutils (diff)
downloadhistorical-31d1807f04b02ee5efe3d00e5190ffc43ed32250.tar.gz
historical-31d1807f04b02ee5efe3d00e5190ffc43ed32250.tar.bz2
historical-31d1807f04b02ee5efe3d00e5190ffc43ed32250.zip
add inherit eutils
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild12
-rw-r--r--dev-lang/lua/lua-5.0.2.ebuild14
2 files changed, 14 insertions, 12 deletions
diff --git a/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild b/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
index 9dc8f5af0b15..176a77607105 100644
--- a/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
+++ b/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
@@ -1,16 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild,v 1.3 2004/02/22 19:55:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild,v 1.4 2004/04/16 02:28:34 vapier Exp $
+
+inherit eutils
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
SRC_URI="http://www.lua.org/ftp/lua-5.0.1.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha -hppa ~mips ~ppc ~sparc ~x86 ~amd64"
IUSE="readline"
+
DEPEND=">=sys-apps/sed-4
sys-apps/findutils"
+
S=${WORKDIR}/lua-5.0.1
src_unpack() {
@@ -34,7 +39,7 @@ src_unpack() {
sed -i doc/readme.html \
-e 's:\(/README\)\("\):\1.gz\2:g'
- if [ `use readline` ]; then
+ if use readline ; then
sed -i config \
-e "s:^#\(USERCONF=-DLUA_USERCONFIG='\"\$(LUA)/etc/saconfig.c\"' -DUSE_READLINE\):\1:" \
-e 's:^#\(EXTRA_LIBS= -lm -ldl -lreadline\) # \(-lhistory -lcurses -lncurses\):\1 \2:'
@@ -54,7 +59,6 @@ Version: ${PV/_*/}
Cflags: -I\${includedir}
Libs: -L\${libdir} -llua -llualib -ldl -lm
EOF
-
}
src_compile() {
@@ -64,7 +68,6 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install soinstall || die "make install soinstall failed"
dodoc COPYRIGHT HISTORY UPDATE
@@ -82,5 +85,4 @@ src_install() {
doins etc/lua.xpm
insinto /usr/lib/pkgconfig
doins etc/lua.pc
-
}
diff --git a/dev-lang/lua/lua-5.0.2.ebuild b/dev-lang/lua/lua-5.0.2.ebuild
index 01381faf2b7f..c9d328125df4 100644
--- a/dev-lang/lua/lua-5.0.2.ebuild
+++ b/dev-lang/lua/lua-5.0.2.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.3 2004/03/29 19:04:12 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.4 2004/04/16 02:29:02 vapier Exp $
+
+inherit eutils
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha -hppa ~mips ~ppc sparc x86 ~amd64"
IUSE="readline"
+
DEPEND=">=sys-apps/sed-4
sys-apps/findutils"
src_unpack() {
-
unpack ${A}
epatch ${FILESDIR}/lua-${PV}-pic.patch
@@ -32,7 +35,7 @@ src_unpack() {
sed -i doc/readme.html \
-e 's:\(/README\)\("\):\1.gz\2:g'
- if [ `use readline` ]; then
+ if use readline ; then
sed -i config \
-e "s:^#\(USERCONF=-DLUA_USERCONFIG='\"\$(LUA)/etc/saconfig.c\"' -DUSE_READLINE\):\1:" \
-e 's:^#\(EXTRA_LIBS= -lm -ldl -lreadline\) # \(-lhistory -lcurses -lncurses\):\1 \2:'
@@ -52,7 +55,6 @@ Version: ${PV}
Cflags: -I\${includedir}
Libs: -L\${libdir} -llua -llualib -ldl -lm
EOF
-
}
src_compile() {
@@ -62,10 +64,9 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install soinstall || die "make install soinstall failed"
- dodoc COPYRIGHT HISTORY UPDATE
+ dodoc HISTORY UPDATE
dohtml doc/*.html doc/*.gif
for i in `find . -name README -printf "%h\n"`; do
docinto ${i#.}
@@ -80,5 +81,4 @@ src_install() {
doins etc/lua.xpm
insinto /usr/lib/pkgconfig
doins etc/lua.pc
-
}