summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-18 20:28:59 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-18 20:28:59 +0000
commitb4a7001c4052b2d069c45c16a00d1ff4a5ccc084 (patch)
tree28f4dfb89a84f8561bc9db8dcc2563bde06c0cd1 /dev-lang/perl/perl-5.8.0-r10.ebuild
parentnew version (diff)
downloadhistorical-b4a7001c4052b2d069c45c16a00d1ff4a5ccc084.tar.gz
historical-b4a7001c4052b2d069c45c16a00d1ff4a5ccc084.tar.bz2
historical-b4a7001c4052b2d069c45c16a00d1ff4a5ccc084.zip
touchups
Diffstat (limited to 'dev-lang/perl/perl-5.8.0-r10.ebuild')
-rw-r--r--dev-lang/perl/perl-5.8.0-r10.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-lang/perl/perl-5.8.0-r10.ebuild b/dev-lang/perl/perl-5.8.0-r10.ebuild
index e9e1f73f52c2..995dbd717d88 100644
--- a/dev-lang/perl/perl-5.8.0-r10.ebuild
+++ b/dev-lang/perl/perl-5.8.0-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.0-r10.ebuild,v 1.9 2003/05/31 00:46:50 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.0-r10.ebuild,v 1.10 2003/06/18 20:28:51 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,16 +52,12 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-
-IUSE="berkdb doc gdbm threads"
-
inherit eutils flag-o-matic
# Perl has problems compiling with -Os in your flags
replace-flags "-Os" "-O2"
# This flag makes compiling crash in interesting ways
-filter-flags "-malign-double"
-
+filter-flags -malign-double
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
@@ -71,7 +67,7 @@ MY_P="${P/lib}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz"
-HOMEPAGE="http://www.perl.org"
+HOMEPAGE="http://www.perl.org/"
if [ "${PN}" = "libperl" ]
then
@@ -84,6 +80,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
KEYWORDS="x86 sparc ppc ~alpha mips ~hppa"
+IUSE="berkdb doc gdbm threads"
DEPEND="sys-apps/groff
berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 )