summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-02-08 04:30:30 +0000
committerMike Gilbert <floppym@gentoo.org>2014-02-08 04:30:30 +0000
commite4fd8c74ad66e2c718c58b485b9cdd7b0681af8a (patch)
treec69ac36ef596872d268651bc341546f956d57dfc /dev-lang/python/python-3.3.3.ebuild
parentDev channel bump. Non-Aura GTK+ UI is now default, but Aura is still availabl... (diff)
downloadhistorical-e4fd8c74ad66e2c718c58b485b9cdd7b0681af8a.tar.gz
historical-e4fd8c74ad66e2c718c58b485b9cdd7b0681af8a.tar.bz2
historical-e4fd8c74ad66e2c718c58b485b9cdd7b0681af8a.zip
Add workaround for race condition when generating Python-ast.c and Python-ast.h. Thanks to Arfrever.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-lang/python/python-3.3.3.ebuild')
-rw-r--r--dev-lang/python/python-3.3.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.3.3.ebuild b/dev-lang/python/python-3.3.3.ebuild
index fab301eff360..63ddd892fe7d 100644
--- a/dev-lang/python/python-3.3.3.ebuild
+++ b/dev-lang/python/python-3.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.16 2014/02/05 04:04:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.17 2014/02/08 04:30:23 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -175,6 +175,9 @@ src_configure() {
}
src_compile() {
+ # http://bugs.python.org/issue19966
+ touch Include/Python-ast.h Python/Python-ast.c || die
+
# Avoid invoking pgen for cross-compiles.
touch Include/graminit.h Python/graminit.c || die