summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-02 17:20:55 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-02 17:20:55 +0000
commit285c805d3a4bc81def9fbef30302be5f4c45470e (patch)
tree6e2814df11840802814c17c313262ab2eef5f26c /dev-lang
parentcleanup, eaip=4, changed to mirror://, version bump (diff)
downloadhistorical-285c805d3a4bc81def9fbef30302be5f4c45470e.tar.gz
historical-285c805d3a4bc81def9fbef30302be5f4c45470e.tar.bz2
historical-285c805d3a4bc81def9fbef30302be5f4c45470e.zip
Add missing dies, remove unnessecary dies, handle static-libs
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/ChangeLog5
-rw-r--r--dev-lang/tcl/tcl-8.5.10.ebuild43
-rw-r--r--dev-lang/tk/ChangeLog5
-rw-r--r--dev-lang/tk/tk-8.5.10.ebuild30
4 files changed, 48 insertions, 35 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 2c4fb900f98a..d2ea22730e10 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.143 2012/03/02 15:30:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.144 2012/03/02 17:16:21 jlec Exp $
+
+ 02 Mar 2012; Justin Lecher <jlec@gentoo.org> tcl-8.5.10.ebuild:
+ Add missing dies, remove unnessecary dies, handle static-libs
02 Mar 2012; Justin Lecher <jlec@gentoo.org> +tcl-8.5.11.ebuild:
Version Bump
diff --git a/dev-lang/tcl/tcl-8.5.10.ebuild b/dev-lang/tcl/tcl-8.5.10.ebuild
index 2f69a55efe15..834a5d94227d 100644
--- a/dev-lang/tcl/tcl-8.5.10.ebuild
+++ b/dev-lang/tcl/tcl-8.5.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.10.ebuild,v 1.3 2012/01/04 20:44:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.10.ebuild,v 1.4 2012/03/02 17:16:21 jlec Exp $
-EAPI="3"
+EAPI=4
inherit autotools eutils flag-o-matic multilib toolchain-funcs
@@ -15,19 +15,19 @@ SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
+IUSE="debug static-libs threads"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use threads ; then
- ewarn ""
+ echo
ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
ewarn "Threading is not supported by all applications"
ewarn "that compile against tcl. You use threading at"
ewarn "your own discretion."
- ewarn ""
+ echo
fi
}
@@ -59,8 +59,7 @@ src_configure() {
}
src_compile() {
- cd "${S}"/unix
- emake || die
+ cd "${S}"/unix && emake
}
src_install() {
@@ -69,7 +68,7 @@ src_install() {
v1=${PV%.*}
cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
+ S= emake DESTDIR="${D}" install
# fix the tclConfig.sh to eliminate refs to the build directory
local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
@@ -83,34 +82,38 @@ src_install() {
[[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] && sed -i \
-e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
-e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh
+ "${ED}"/usr/${mylibdir}/tclConfig.sh || die
# install private headers
insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h || die
+ doins "${S}"/unix/*.h
insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
+ doins "${S}"/generic/*.h
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h || die
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h || die
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
# install symlink for libraries
- dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname) || die
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a || die
+ dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
+ if use static-libs; then
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
+ else
+ rm -f "${ED}"/usr/${mylibdir}/*.a || die
+ fi
- dosym tclsh${v1} /usr/bin/tclsh || die
+ dosym tclsh${v1} /usr/bin/tclsh
cd "${S}"
- dodoc ChangeLog* README changes || die
+ dodoc ChangeLog* README changes
}
pkg_postinst() {
- ewarn
+ echo
ewarn "If you're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
ewarn "packages on your system that link with tcl after the upgrade"
ewarn "completes. To perform this action, please run revdep-rebuild"
ewarn "in package app-portage/gentoolkit."
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
- ewarn
+ echo
}
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 56fb3319353a..6908cd6db890 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.156 2012/03/02 15:31:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.157 2012/03/02 17:20:55 jlec Exp $
+
+ 02 Mar 2012; Justin Lecher <jlec@gentoo.org> tk-8.5.10.ebuild:
+ Add missing dies, remove unnessecary dies, handle static-libs
*tk-8.5.11 (02 Mar 2012)
diff --git a/dev-lang/tk/tk-8.5.10.ebuild b/dev-lang/tk/tk-8.5.10.ebuild
index 2307f131b963..f4fa21fc5ec9 100644
--- a/dev-lang/tk/tk-8.5.10.ebuild
+++ b/dev-lang/tk/tk-8.5.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.10.ebuild,v 1.1 2011/10/04 17:08:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.10.ebuild,v 1.2 2012/03/02 17:20:55 jlec Exp $
-EAPI="3"
+EAPI=4
inherit autotools eutils multilib toolchain-funcs prefix
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug threads truetype aqua xscreensaver"
+IUSE="debug static-libs threads truetype aqua xscreensaver"
RDEPEND="
!aqua? (
@@ -60,8 +60,7 @@ src_configure() {
}
src_compile() {
- cd "${S}"/unix
- emake || die
+ cd "${S}"/unix && emake
}
src_install() {
@@ -70,7 +69,7 @@ src_install() {
v1=${PV%.*}
cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
+ S= emake DESTDIR="${D}" install
# normalize $S path, bug #280766 (pkgcore)
local nS="$(cd "${S}"; pwd)"
@@ -93,20 +92,25 @@ src_install() {
# install private headers
insinto /usr/${mylibdir}/tk${v1}/include/unix
- doins "${S}"/unix/*.h || die
+ doins "${S}"/unix/*.h
insinto /usr/${mylibdir}/tk${v1}/include/generic
- doins "${S}"/generic/*.h || die
+ doins "${S}"/generic/*.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
# install symlink for libraries
#dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
- dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname) || die
- dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a || die
+ dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname)
+
+ if use static-libs; then
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
+ else
+ rm -f "${ED}"/usr/${mylibdir}/*.a || die
+ fi
- dosym wish${v1} /usr/bin/wish || die
+ dosym wish${v1} /usr/bin/wish
cd "${S}"
- dodoc ChangeLog* README changes || die
+ dodoc ChangeLog* README changes
}