summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-10-22 04:03:30 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-10-22 04:03:30 +0000
commitb2ad10bfe1677db26b275bdd475c0b51d7f7fdb7 (patch)
tree9ef1c1ad40752eac78cf970398195ef9c9d1584b /dev-libs/boost
parentpatch from airsnort to allow our pcmcia-cs to work with kismet (bug 7242) (diff)
downloadhistorical-b2ad10bfe1677db26b275bdd475c0b51d7f7fdb7.tar.gz
historical-b2ad10bfe1677db26b275bdd475c0b51d7f7fdb7.tar.bz2
historical-b2ad10bfe1677db26b275bdd475c0b51d7f7fdb7.zip
new version
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog12
-rw-r--r--dev-libs/boost/boost-1.29.0.ebuild54
-rw-r--r--dev-libs/boost/files/digest-boost-1.29.01
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 5bd7119b2cc7..934d088232c1 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -2,9 +2,15 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.3 2002/05/07 03:58:19 drobbins Exp
+*boost-1.29.0 (21 Oct 2002)
+
+ 21 Oct 2002; Maik Schreiber <blizzy@gentoo.org> : New version, closes bug
+ #9461.
+
*boost-1.28 (19 Oct 2002)
- 19 Oct 2002; Karl Trygve Kalleberg <markus-krainer@chello.at> boost-1.28.0.ebuild, files/digest-boost-1.28:
- Initial import. All code submitted by Markus Krainer
- <markus-krainer@chello.at>. Fixes #2851.
+123456789-123456789-123456789-123456789-123456789-123456789-123456789-123456789-
+ 19 Oct 2002; Karl Trygve Kalleberg <markus-krainer@chello.at>
+ boost-1.28.0.ebuild, files/digest-boost-1.28: Initial import. All code
+ submitted by Markus Krainer <markus-krainer@chello.at>. Fixes #2851.
diff --git a/dev-libs/boost/boost-1.29.0.ebuild b/dev-libs/boost/boost-1.29.0.ebuild
new file mode 100644
index 000000000000..c669fc179e7c
--- /dev/null
+++ b/dev-libs/boost/boost-1.29.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.29.0.ebuild,v 1.1 2002/10/22 04:03:30 blizzy Exp $
+
+MY_V="${PV//\./_}"
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+SRC_URI="http://boost.sourceforge.net/release/boost_${MY_V}.tar.gz"
+LICENSE="freedist"
+KEYWORDS="~x86"
+SLOT="1"
+IUSE=""
+
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1"
+
+S="${WORKDIR}/boost_${MY_V}"
+
+src_compile() {
+ # first compile jam (the boost build tool)
+ cd ${S}/tools/build/jam_src
+ emake || die "couldn't build jam"
+
+ # now build boost libraries
+ cd ${S}
+ ./tools/build/jam_src/bin.linuxx86/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=2.2 \
+ -sTOOLS=gcc || die "build error"
+}
+
+src_install () {
+ # jam does not provide smth like 'make install' :(
+
+ cd ${S}
+ # install libraries
+ find libs -type f -name \*.a -exec dolib.a {} \;
+ find libs -type f -name \*.so -exec dolib.so {} \;
+
+ # install source/header files
+ find boost -type f -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install documentation
+ dodoc README
+
+ # this part should really use dohtml -- karltk
+ for i in htm html jpg jpeg gif css
+ do
+ find . -type f -name "*.${i}" -exec \
+ install -D -m0644 {} ${D}/usr/share/doc/${P}/html/{} \;
+ done
+}
diff --git a/dev-libs/boost/files/digest-boost-1.29.0 b/dev-libs/boost/files/digest-boost-1.29.0
new file mode 100644
index 000000000000..fc4262e9e3dc
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.29.0
@@ -0,0 +1 @@
+MD5 258243a3b553ab0a3937aa9ea3165351 boost_1_29_0.tar.gz 5398510