summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-23 20:34:42 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-23 20:34:42 +0000
commit839b8573e008fc8151344c79245e847f834fa196 (patch)
treeeb396440e752639f581f429723710fe2eef17d34 /dev-libs/cyrus-sasl
parentJust fixing a b0rked date caused by copying and pasting incorrectly :P (diff)
downloadhistorical-839b8573e008fc8151344c79245e847f834fa196.tar.gz
historical-839b8573e008fc8151344c79245e847f834fa196.tar.bz2
historical-839b8573e008fc8151344c79245e847f834fa196.zip
Added a gssap-segfault.patch. Needs testing.
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog10
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.10-r1.ebuild117
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.10-r11
-rw-r--r--dev-libs/cyrus-sasl/files/gssapi-sefault.patch29
4 files changed, 156 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 952ede9dd0d8..a035af7be2b6 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.30 2002/12/27 21:50:27 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.31 2003/01/23 20:34:42 raker Exp $
+
+*cyrus-2.1.10-r1 (23 Jan 2003)
+
+ 23 Jan 2003; Nick Hadaway <raker@gentoo.org> cyrus-sasl-2.1.10-r1.ebuild,
+ files/digest-cyrus-sasl-2.1.10-r1 :
+ http://asg.web.cmu.edu/archive/message.php?mailbox=archive-sasl&msg=3066
+ Added a patch to see if that will help with problems noted in bug
+ #13116
*cyrus-sasl-2.1.10 (14 Dec 2002)
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.10-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.10-r1.ebuild
new file mode 100644
index 000000000000..72afd331c1cf
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.10-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.10-r1.ebuild,v 1.1 2003/01/23 20:34:42 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="x86 ~ppc -sparc "
+
+IUSE="gdbm berkdb ldap mysql kerberos"
+
+inherit eutils
+
+RDEPEND=">=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/openssl-0.9.6d
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3.2.9 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # Fix depends for heimdal needed in saslv2 too
+ epatch ${FILESDIR}/${PN}2-heimdal-deps.patch
+
+ # Fix for gssapi seg faulting problem?
+ epatch ${FILESDIR}/gssapi-sefault.patch
+}
+
+src_compile() {
+
+ local myconf
+
+ libtoolize --copy --force
+ aclocal -I config -I cmulocal || die
+ autoheader || die
+ automake -a --foreign || die
+ autoconf || die
+ autoconf saslauthd/configure.in > saslauthd/configure || die
+ chmod +x saslauthd/configure || die
+
+ use ldap && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ if use berkdb; then
+ myconf="${myconf} --with-dblib=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --with-dblib=gdbm --with-gdbm=/usr"
+ else
+ myconf="${myconf} --with-dblib=berkeley"
+ fi
+
+ use static && myconf="${myconf} --enable-static --with-staticsasl" \
+ || myconf="${myconf} --disable-static --without-staticsasl"
+
+ use kerberos && myconf="${myconf} --enable-gssapi=/usr" \
+ || myconf="${myconf} --disable-gssapi"
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-openssl \
+ --with-plugindir=/usr/lib/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ --with-des \
+ --with-rc4 \
+ --disable-krb4 \
+ --with-gnu-ld \
+ --enable-shared \
+ --disable-sample \
+ --enable-login \
+ ${myconf} || die "bad ./configure"
+
+ make MAKE=emake || die "compile problem"
+}
+
+src_install () {
+
+ einstall || die "install problem"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ dodir /var/lib/sasl2
+ dodir /etc/sasl2
+ # generate an empty sasldb2 with correct permissions
+ LD_OLD=${LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH=${S}/lib/.libs
+ echo "gentoo" | ${D}usr/sbin/saslpasswd2 -f ${D}etc/sasl2/sasldb2 -p cyrus
+ ${D}usr/sbin/saslpasswd2 -f ${D}etc/sasl2/sasldb2 -d cyrus
+ export LD_LIBRARY_PATH=${LD_OLD}
+ chown root.mail ${D}etc/sasl2/sasldb2
+ chmod 0640 ${D}etc/sasl2/sasldb2
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd2.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.10-r1 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.10-r1
new file mode 100644
index 000000000000..bc95eab8e136
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.10-r1
@@ -0,0 +1 @@
+MD5 3ac2a696c091a76ce6c7db27e5d859d4 cyrus-sasl-2.1.10.tar.gz 1325286
diff --git a/dev-libs/cyrus-sasl/files/gssapi-sefault.patch b/dev-libs/cyrus-sasl/files/gssapi-sefault.patch
new file mode 100644
index 000000000000..0a87a7b0d597
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/gssapi-sefault.patch
@@ -0,0 +1,29 @@
+diff -urN cyrus-sasl-2.1.10/plugins/gssapi.c cyrus-sasl-2.1.10-modified/plugins/gssapi.c
+--- cyrus-sasl-2.1.10/plugins/gssapi.c 2002-09-19 13:37:10.000000000 -0500
++++ cyrus-sasl-2.1.10-modified/plugins/gssapi.c 2003-01-23 14:21:19.000000000 -0600
+@@ -999,9 +999,9 @@
+ }
+
+ /* No matter what, set the rest of the oparams */
+- oparams->maxoutbuf = (((char *) output_token->value)[1] << 16) |
+- (((char *) output_token->value)[2] << 8) |
+- (((char *) output_token->value)[3] << 0);
++ oparams->maxoutbuf = (((unsigned char *) output_token->value)[1] << 16) |
++ (((unsigned char *) output_token->value)[2] << 8) |
++ (((unsigned char *) output_token->value)[3] << 0);
+
+ if (oparams->mech_ssf) {
+ /* xxx this is probably too big */
+@@ -1413,9 +1413,9 @@
+ return SASL_TOOWEAK;
+ }
+
+- oparams->maxoutbuf = (((char *) output_token->value)[1] << 16) |
+- (((char *) output_token->value)[2] << 8) |
+- (((char *) output_token->value)[3] << 0);
++ oparams->maxoutbuf = (((unsigned char *) output_token->value)[1] << 16) |
++ (((unsigned char *) output_token->value)[2] << 8) |
++ (((unsigned char *) output_token->value)[3] << 0);
+
+ if(oparams->mech_ssf) {
+ /* xxx probably too large */