summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-01-30 15:01:19 +0000
committerThomas Sachau <tommy@gentoo.org>2011-01-30 15:01:19 +0000
commit83902727cb4e15e2f212873354cd8be23662718b (patch)
tree4d164d8cabed2a776c6d28d00c4026bd725a22ed /dev-libs/e_dbus
parentInstall PDF documentation only with USE="doc". (diff)
downloadhistorical-83902727cb4e15e2f212873354cd8be23662718b.tar.gz
historical-83902727cb4e15e2f212873354cd8be23662718b.tar.bz2
historical-83902727cb4e15e2f212873354cd8be23662718b.zip
Version bump, drop old
Package-Manager: portage-2.2.0_alpha19-r1/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/e_dbus')
-rw-r--r--dev-libs/e_dbus/ChangeLog10
-rw-r--r--dev-libs/e_dbus/e_dbus-1.0.0.ebuild53
-rw-r--r--dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild38
3 files changed, 61 insertions, 40 deletions
diff --git a/dev-libs/e_dbus/ChangeLog b/dev-libs/e_dbus/ChangeLog
index 304ed2d68ad5..c087be153992 100644
--- a/dev-libs/e_dbus/ChangeLog
+++ b/dev-libs/e_dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/e_dbus
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.2 2010/12/17 18:45:42 tommy Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.3 2011/01/30 14:55:02 tommy Exp $
+
+*e_dbus-1.0.0 (30 Jan 2011)
+
+ 30 Jan 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -e_dbus-1.0.0_beta2.ebuild, +e_dbus-1.0.0.ebuild:
+ Version bump, drop old
*e_dbus-1.0.0_beta3 (17 Dec 2010)
diff --git a/dev-libs/e_dbus/e_dbus-1.0.0.ebuild b/dev-libs/e_dbus/e_dbus-1.0.0.ebuild
new file mode 100644
index 000000000000..66f3804abfb8
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.0.0.ebuild,v 1.1 2011/01/30 14:55:02 tommy Exp $
+
+EAPI="2"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth +connman hal +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/eina-1.0.0_beta
+ >=dev-libs/ecore-1.0.0_beta
+ sys-apps/dbus
+ libnotify? ( >=media-libs/evas-1.0.0_beta )
+ hal? ( sys-apps/hal )
+ udev? ( sys-power/upower sys-fs/udisks )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman)
+ $(use_enable doc)
+ $(use_enable hal ehal)
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)"
+ if use test-binaries ; then
+ MY_ECONF+="
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)"
+ else
+ MY_ECONF+="
+ --disable-edbus-bluez-test
+ --disable-edbus-connman-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test"
+ fi
+ enlightenment_src_configure
+}
diff --git a/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild b/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild
deleted file mode 100644
index e60a61be4ff5..000000000000
--- a/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.0.0_beta2.ebuild,v 1.1 2010/11/18 14:14:59 tommy Exp $
-
-EAPI="2"
-
-MY_P=${P/_beta/.beta}
-
-inherit enlightenment
-
-DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
-SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="bluetooth +connman +hal +libnotify ofono static-libs ukit"
-
-RDEPEND=">=dev-libs/eina-1.0.0_beta
- >=dev-libs/ecore-1.0.0_beta
- sys-apps/dbus
- libnotify? ( >=media-libs/evas-1.0.0_beta )
- hal? ( sys-apps/hal )
- ukit? ( sys-power/upower sys-fs/udisks )
-"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- MY_ECONF="
- $(use_enable bluetooth ebluez)
- $(use_enable connman econnman)
- $(use_enable doc)
- $(use_enable hal ehal)
- $(use_enable libnotify enotify)
- $(use_enable ofono eofono)
- $(use_enable ukit eukit)
- "
- enlightenment_src_configure
-}