summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-25 17:02:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-25 17:02:00 +0000
commit339036518d32c91bce3a5df313bb46d6bd7a44dd (patch)
tree101fa4bbe423f53a714875394437a90e7b888eca /dev-libs/libev/libev-4.01.ebuild
parentBetter solution for the missing constants.pxi (diff)
downloadhistorical-339036518d32c91bce3a5df313bb46d6bd7a44dd.tar.gz
historical-339036518d32c91bce3a5df313bb46d6bd7a44dd.tar.bz2
historical-339036518d32c91bce3a5df313bb46d6bd7a44dd.zip
Version Bump, #346773
Package-Manager: portage-2.2.0_alpha5/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libev/libev-4.01.ebuild')
-rw-r--r--dev-libs/libev/libev-4.01.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-4.01.ebuild b/dev-libs/libev/libev-4.01.ebuild
new file mode 100644
index 000000000000..c487d9dabe5c
--- /dev/null
+++ b/dev-libs/libev/libev-4.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-4.01.ebuild,v 1.1 2010/11/25 17:02:00 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${P}"
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README || die
+}