summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-10-02 08:54:25 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-10-02 08:54:25 +0000
commit633194d0247ecc2aff02bc2516b2e4dea05dc98a (patch)
tree6a426001df00e68d20af3cf7e5b9d9483af1645b /dev-libs/libpcre/libpcre-8.30-r2.ebuild
parentVersion bump (diff)
downloadhistorical-633194d0247ecc2aff02bc2516b2e4dea05dc98a.tar.gz
historical-633194d0247ecc2aff02bc2516b2e4dea05dc98a.tar.bz2
historical-633194d0247ecc2aff02bc2516b2e4dea05dc98a.zip
Version bump. Removed old.
Package-Manager: portage-2.2.14_rc1/cvs/Linux x86_64 Manifest-Sign-Key: 0x981CA6FC
Diffstat (limited to 'dev-libs/libpcre/libpcre-8.30-r2.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-8.30-r2.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-libs/libpcre/libpcre-8.30-r2.ebuild b/dev-libs/libpcre/libpcre-8.30-r2.ebuild
deleted file mode 100644
index 10e7c7db387a..000000000000
--- a/dev-libs/libpcre/libpcre-8.30-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.30-r2.ebuild,v 1.14 2014/04/29 19:28:59 vapier Exp $
-
-EAPI="4"
-
-inherit eutils multilib libtool flag-o-matic toolchain-funcs
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-MY_P="pcre-${PV/_rc/-RC}"
-if [[ ${PV} != *_rc* ]] ; then
- # Only the final releases are available here.
- SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
- ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 +cxx +jit pcre16 +readline +recursion-limit static-libs unicode zlib"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
- epatch "${FILESDIR}"/${P}-bzip2-typo.patch #418033
- elibtoolize
-}
-
-src_configure() {
- econf \
- --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
- $(use_enable bzip2 pcregrep-libbz2) \
- $(use_enable cxx cpp) \
- $(use_enable jit) $(use_enable jit pcregrep-jit) \
- $(use_enable pcre16) \
- $(use_enable readline pcretest-libreadline) \
- $(use_enable static-libs static) \
- $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
- $(use_enable zlib pcregrep-libz) \
- --enable-pcre8 \
- --enable-shared \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- gen_usr_ldscript -a pcre
- find "${D}" -type f -name '*.la' -exec rm -f {} +
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/libpcre.so.0
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
-}