summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-28 13:32:31 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-28 13:32:31 +0000
commit51d3d4e6df052f1e091c973b2225394a670ab6e6 (patch)
treec274df48fa46de22bdb8df971c6ecc812b5dd686 /dev-libs/libxslt
parentintial ebuild submission (diff)
downloadhistorical-51d3d4e6df052f1e091c973b2225394a670ab6e6.tar.gz
historical-51d3d4e6df052f1e091c973b2225394a670ab6e6.tar.bz2
historical-51d3d4e6df052f1e091c973b2225394a670ab6e6.zip
New version (gnome2.1 commit)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog8
-rw-r--r--dev-libs/libxslt/files/digest-libxslt-1.0.221
-rw-r--r--dev-libs/libxslt/libxslt-1.0.22.ebuild43
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index c77426f50b59..bf1237526685 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.12 2002/09/17 15:40:19 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.13 2002/10/28 13:32:30 foser Exp $
+
+*libxslt-1.0.22 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> libxslt-1.0.22.ebuild :
+
+ Gnome 2.1 commit
*libxslt-1.0.20 (06 Sep 2002)
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.0.22 b/dev-libs/libxslt/files/digest-libxslt-1.0.22
new file mode 100644
index 000000000000..efe26b9f9d0c
--- /dev/null
+++ b/dev-libs/libxslt/files/digest-libxslt-1.0.22
@@ -0,0 +1 @@
+MD5 c4ba40a58ba1892310af50b69da3aa11 libxslt-1.0.22.tar.bz2 1518479
diff --git a/dev-libs/libxslt/libxslt-1.0.22.ebuild b/dev-libs/libxslt/libxslt-1.0.22.ebuild
new file mode 100644
index 000000000000..f1171764ed7e
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.0.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.22.ebuild,v 1.1 2002/10/28 13:32:30 foser Exp $
+
+inherit libtool gnome.org debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XSLT libraries and tools"
+#SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+
+RDEPEND=">=dev-libs/libxml2-2.4.25"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ econf || die
+ #libxslt-1.0.19 didn't like parallel make; test a good deal before re-enabling
+ #(drobbins, 24 Jul 2002)
+ patch -p0 < ${FILESDIR}/Makefile-py.patch
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}