summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-19 20:19:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-19 20:19:57 +0000
commit1958dc3fa8bca8d3bb0c841e92c67f3a7e5e7983 (patch)
tree64faf3c84f935c6c71636488fd1e420669c085fa /dev-libs/rasqal
parentInstall missing symlinks. Trivial, commit to stable. (diff)
downloadhistorical-1958dc3fa8bca8d3bb0c841e92c67f3a7e5e7983.tar.gz
historical-1958dc3fa8bca8d3bb0c841e92c67f3a7e5e7983.tar.bz2
historical-1958dc3fa8bca8d3bb0c841e92c67f3a7e5e7983.zip
Add support for dev-libs/dmalloc by using USE debug.
Package-Manager: portage-2.1.4
Diffstat (limited to 'dev-libs/rasqal')
-rw-r--r--dev-libs/rasqal/ChangeLog5
-rw-r--r--dev-libs/rasqal/rasqal-0.9.15.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-libs/rasqal/ChangeLog b/dev-libs/rasqal/ChangeLog
index 6996b9a7121b..b08e5e67c18f 100644
--- a/dev-libs/rasqal/ChangeLog
+++ b/dev-libs/rasqal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/rasqal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.15 2008/01/18 20:45:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.16 2008/01/19 20:19:57 drac Exp $
+
+ 19 Jan 2008; Samuli Suominen <drac@gentoo.org> rasqal-0.9.15.ebuild:
+ Add support for dev-libs/dmalloc by using USE debug.
*rasqal-0.9.15 (18 Jan 2008)
diff --git a/dev-libs/rasqal/rasqal-0.9.15.ebuild b/dev-libs/rasqal/rasqal-0.9.15.ebuild
index aedbf32fc906..d04efea22e91 100644
--- a/dev-libs/rasqal/rasqal-0.9.15.ebuild
+++ b/dev-libs/rasqal/rasqal-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.15.ebuild,v 1.2 2008/01/18 23:03:09 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.15.ebuild,v 1.3 2008/01/19 20:19:57 drac Exp $
inherit libtool
@@ -11,13 +11,14 @@ SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
LICENSE="LGPL-2.1 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="gmp pcre xml"
+IUSE="debug gmp pcre xml"
RDEPEND=">=media-libs/raptor-1.4.16
pcre? ( dev-libs/libpcre )
xml? ( dev-libs/libxml2 )
!gmp? ( dev-libs/mpfr )
- gmp? ( dev-libs/gmp )"
+ gmp? ( dev-libs/gmp )
+ debug? ( >=dev-libs/dmalloc-5.5.2-r2 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -43,9 +44,9 @@ src_compile() {
decimal="mpfr"
fi
- econf $(use_enable pcre) $(use_enable xml xml2) \
- --with-raptor=system --with-regex-library=${regex} \
- --with-decimal=${decimal}
+ econf $(use_enable pcre) $(use_enable xml xml2) $(use_with debug dmalloc) \
+ $(use_enable debug maintainer-mode) --with-regex-library=${regex} \
+ --with-decimal=${decimal} --with-raptor=system
emake || die "emake failed."
}