summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2009-05-23 10:54:17 +0000
committerThomas Anderson <tanderson@gentoo.org>2009-05-23 10:54:17 +0000
commitbb51f0ce60060a7168f441658393e4c2e63e9782 (patch)
tree8aa8985b7ff57c278b39e636179f73a15c886a84 /dev-libs/stfl/files
parentx86 stable, bug #270811 (diff)
downloadhistorical-bb51f0ce60060a7168f441658393e4c2e63e9782.tar.gz
historical-bb51f0ce60060a7168f441658393e4c2e63e9782.tar.bz2
historical-bb51f0ce60060a7168f441658393e4c2e63e9782.zip
Remove mention of stfl.pyc from Makefiles and stop automatic generation of stfl.pyc by doing 'python -c stfl' in the buildsystem. Also fix a parallel build bug produced (partly) by the stfl.pyc stuff. Thanks to Christian Weiske for the report in bug #262006 and Ihar Hrachyshka for the initial patch.
Package-Manager: portage-2.1.6.11/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/stfl/files')
-rw-r--r--dev-libs/stfl/files/stfl-0.19-multilib.patch55
1 files changed, 40 insertions, 15 deletions
diff --git a/dev-libs/stfl/files/stfl-0.19-multilib.patch b/dev-libs/stfl/files/stfl-0.19-multilib.patch
index a32b09f0f566..d1c01e7c2e3d 100644
--- a/dev-libs/stfl/files/stfl-0.19-multilib.patch
+++ b/dev-libs/stfl/files/stfl-0.19-multilib.patch
@@ -1,7 +1,17 @@
-diff -aur stfl-0.19-orig/Makefile stfl-0.19/Makefile
---- stfl-0.19-orig/Makefile 2007-09-19 19:24:14.000000000 -0400
-+++ stfl-0.19/Makefile 2008-09-02 20:05:10.000000000 -0400
-@@ -50,9 +50,9 @@
+diff --git stfl-0.19/Makefile stfl-0.19-ta/Makefile
+index f098187..80dd338 100644
+--- stfl-0.19/Makefile
++++ stfl-0.19-ta/Makefile
+@@ -39,7 +39,7 @@ clean:
+ rm -f widgets/*.o spl/mod_stfl.so spl/example.db
+ cd perl5 && perl Makefile.PL && make clean && rm -f Makefile.old
+ rm -f perl5/stfl_wrap.c perl5/stfl.pm perl5/build_ok
+- rm -f python/stfl.py python/stfl.pyc python/_stfl.so
++ rm -f python/stfl.py python/_stfl.so
+ rm -f python/stfl_wrap.c python/stfl_wrap.o
+ rm -f ruby/Makefile ruby/stfl_wrap.c ruby/stfl_wrap.o
+ rm -f ruby/stfl.so ruby/build_ok Makefile.deps_new
+@@ -50,9 +50,9 @@ Makefile.deps: *.c widgets/*.c *.h
mv -f Makefile.deps_new Makefile.deps
install: all
@@ -13,26 +23,41 @@ diff -aur stfl-0.19-orig/Makefile stfl-0.19/Makefile
install -m 644 stfl.h $(DESTDIR)$(prefix)/include/
ifeq ($(FOUND_SPL),1)
-diff -aur stfl-0.19-orig/python/Makefile.snippet stfl-0.19/python/Makefile.snippet
---- stfl-0.19-orig/python/Makefile.snippet 2007-09-03 12:13:04.000000000 -0400
-+++ stfl-0.19/python/Makefile.snippet 2008-09-02 20:00:40.000000000 -0400
-@@ -32,8 +32,8 @@
- cd python && python -c 'import stfl'
+diff --git stfl-0.19/python/Makefile.snippet stfl-0.19-ta/python/Makefile.snippet
+index 65e7a3d..a8d830c 100644
+--- stfl-0.19/python/Makefile.snippet
++++ stfl-0.19-ta/python/Makefile.snippet
+@@ -21,19 +21,17 @@
- install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+ PYTHON_VERSION = $(shell python -V 2>&1 | cut -f2 -d' ' | cut -f1-2 -d'.')
+
+-all: python/_stfl.so python/stfl.py python/stfl.pyc
++all: python/_stfl.so python/stfl.py
+
+ install: install_python
+
+-python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i swig/*.i
++python/_stfl.so python/stfl.py: libstfl.a stfl.h python/stfl.i swig/*.i
+ cd python && swig -python stfl.i
+ gcc -shared -pthread -fPIC python/stfl_wrap.c -I/usr/include/python$(PYTHON_VERSION) \
+ -I. libstfl.a -lncursesw -o python/_stfl.so
+- cd python && python -c 'import stfl'
+
+-install_python: python/_stfl.so python/stfl.py python/stfl.pyc
- mkdir -p $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/lib-dynload/
- cp python/_stfl.so $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/lib-dynload/
- cp python/stfl.pyc $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/
- cp python/stfl.py $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/
++install_python: python/_stfl.so python/stfl.py
+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/lib-dynload/
-+ cp python/stfl.pyc $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/
+ cp python/stfl.py $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/
-diff -aur stfl-0.19-orig/ruby/Makefile.snippet stfl-0.19/ruby/Makefile.snippet
---- stfl-0.19-orig/ruby/Makefile.snippet 2007-09-03 12:13:04.000000000 -0400
-+++ stfl-0.19/ruby/Makefile.snippet 2008-09-02 20:02:40.000000000 -0400
-@@ -25,9 +25,9 @@
+diff --git stfl-0.19/ruby/Makefile.snippet stfl-0.19-ta/ruby/Makefile.snippet
+index 74dfa9b..f0ced6f 100644
+--- stfl-0.19/ruby/Makefile.snippet
++++ stfl-0.19-ta/ruby/Makefile.snippet
+@@ -25,9 +25,9 @@ install: install_ruby
ruby/build_ok: libstfl.a stfl.h ruby/stfl.i swig/*.i
cd ruby && swig -ruby stfl.i && ruby extconf.rb